Jump to content


Photo
- - - - -

Canon DLSR 'Error 20'


  • Please log in to reply
2 replies to this topic

#1 sunnyboy010101

sunnyboy010101

    Lionfish

  • Member
  • PipPip
  • 64 posts
  • Gender:Male
  • Location:Vancouver Island

Posted 26 October 2017 - 11:58 AM

I have a Canon 7D (mark 1). Recently it started giving an "Error 20". Searching the internet this error appears to be a problem with the mirror movement mechanism.

 

Has anyone experienced this problem, and is there any solution other than sending the camera back to Canon for service?

 

My problem is the only service center shown for Canada is the other side of the country (Ontario), which means expensive shipping (and  possible loss).

 

I'm wondering if there's a quick fix or workaround.



#2 bvanant

bvanant

    Sperm Whale

  • Team Wetpixel
  • 1825 posts
  • Gender:Male
  • Location:Los Angeles (more or less)
  • Interests:Science, photography, travel

Posted 27 October 2017 - 12:00 PM

Err 20

Description: A malfunction with the mechanical mechanism has been detected.

Resolution: Turn the power off, then remove and re-install the battery. Then turn the power on again.


Bill
Canon 7d, Nauticam, Lots of glass, Olympus OMD-EM5, Nauticam, 60 macro, 45 macro, 8 mm fisheye, Inon, S&S, Athena Strobes plus lots of fiddly bits.
www.blueviews.net


#3 sunnyboy010101

sunnyboy010101

    Lionfish

  • Member
  • PipPip
  • 64 posts
  • Gender:Male
  • Location:Vancouver Island

Posted 27 October 2017 - 01:48 PM

Yea, that' s the error. So far I'm good just powering off and on again. I've yet to have to pull the battery. I've read enough to know it's something involving the mirror lock-up when taking a shot, but there's been nothing else posted that I can find. Everyone so far ends up sending it back for service, but I'm trying/hoping to avoid that.