Jump to content


Photo
- - - - -

New Inon Z330


  • Please log in to reply
108 replies to this topic

#101 jmark18

jmark18

    Moray Eel

  • Member
  • PipPip
  • 85 posts
  • Gender:Male
  • Location:Ontario,Canada

Posted 03 June 2018 - 11:17 PM

I am shooting with a Nikon D7000. After some reading I understand that I want the preflash button in the down position. Thanks

#102 adamhanlon

adamhanlon

    Harbor Seal

  • Admin
  • 2221 posts
  • Gender:Male
  • Location:Lancaster, UK

Posted 04 June 2018 - 03:11 AM

Actually, the type of camera is less important than how the strobe's output is being controlled. 

 

If you wish to shoot with manual flash output control, then the "Pre-Flash Cancellation" button should be in the in (down) position.

 

If you wish to shoot using TTL flash/exposure output control, the "Pre-Flash Cancellation" button should be in the out (up) position.

 

Of course, your camera settings control whether the camera is supplying a manual or TTL flash signal, so this needs setting in your camera menu too. 

 

Adam


Adam Hanlon-underwater photographer and videographer
Editor-wetpixel
web | Flickr | twitter | Linkedin | Facebook


#103 jmark18

jmark18

    Moray Eel

  • Member
  • PipPip
  • 85 posts
  • Gender:Male
  • Location:Ontario,Canada

Posted 04 June 2018 - 03:49 AM

Got it

#104 jmo

jmo

    Hermit Crab

  • Member
  • Pip
  • 3 posts
  • Gender:Male

Posted 30 August 2018 - 09:06 AM

I am currently using the INON Z-240 strobes (the old type 2).

 

Does anybody know whether I can use the same optical cables with the new INON Z-330 strobe ?

(see pictures)

 

Thank You.

 

Kind regards,

Jesper

Attached Images

  • _DSC7800.jpg
  • _DSC7803.jpg


#105 Walt Stearns

Walt Stearns

    Eagle Ray

  • Industry
  • PipPipPip
  • 379 posts
  • Gender:Male
  • Location:West Palm Beach, Florida
  • Interests:Diving and underwater photography of course with a little rebreathers, cave diving, marine science and natural history thrown in.

Posted 30 August 2018 - 10:46 AM

I have the Z330's. Seems to be the same connection.



#106 jmo

jmo

    Hermit Crab

  • Member
  • Pip
  • 3 posts
  • Gender:Male

Posted 31 August 2018 - 04:01 AM

Thanks, Walt.

 

I was just a bit worried because the sensor on my old "Z-240 type 2" strobe looks bigger to me than the one on the Z-330 strobe.

 

/Jesper



#107 spyros.spyrou

spyros.spyrou

    Clownfish

  • Member
  • Pip
  • 27 posts

Posted 08 September 2018 - 07:21 AM

I have the Z330's. Seems to be the same connection.


Walt hi.

Do you know if they are the same on s2000 strobes?

Thanks.

Spyros


Sent from my iPhone using Tapatalk

#108 hellhole

hellhole

    Sting Ray

  • Member
  • PipPipPip
  • 214 posts

Posted 09 September 2018 - 02:02 AM

Same for all... The type 2 have a bigger fiber 'knob'

#109 pbalves

pbalves

    Wolf Eel

  • Member
  • PipPip
  • 102 posts
  • Gender:Male
  • Location:Portugal

Posted 09 September 2018 - 06:40 AM

The cable for type 2 works on type 4 and probably the same on z330.
The other way arround is not true.

The screw is the same size.

Edited by pbalves, 09 September 2018 - 06:40 AM.