Jump to content


Photo
- - - - -

Intova Galaxy Fluctuations

Video Lights Intova Galaxy Issues Problems Troubleshoot

  • Please log in to reply
1 reply to this topic

#1 DeepDivinDave

DeepDivinDave

    Hermit Crab

  • Member
  • Pip
  • 3 posts

Posted 01 June 2014 - 12:22 PM

Hey all, 

 

I just picked up a pair of Intova Galaxy's and upon charging and lighting them up to do a full battery drain test I noticed that while on the high setting the lights will occasionally (maybe once every minute or two) drop in intensity for about 30 seconds and then power back up to full.  At first I thought it was just one light, but after troubleshooting more I've seen both do it a number of times.  

 

Has anyone else experienced this?  Is it something that is solved when the lights are submerged vs. above water?  Is it just the lights trying to keep from overheating?  

 

Any thoughts or previous experiences with this would be tremendously helpful.

 

Cheers,

 

Dave



#2 DeepDivinDave

DeepDivinDave

    Hermit Crab

  • Member
  • Pip
  • 3 posts

Posted 15 June 2014 - 05:46 PM

So if anyone is interested, I just took my two galaxy's to Hawaii and the intensity issue resolved itself when used underwater.  So I'm fairly sure they were just overheating.  I did however see a flicker in the lights on a low and medium setting in low/no light situations.  I've seen this issue before on the web and supposedly Intova has found a solution.  So once I deal with them, I'll let you know how they operate on low/med.







Also tagged with one or more of these keywords: Video Lights, Intova, Galaxy, Issues, Problems, Troubleshoot