Jump to content


xberg's Content

There have been 4 items by xberg (Search limited from 16-August 17)


By content type

See this member's

Sort by                Order  

#80444 Bonica Strobe - recommendations?

Posted by xberg on 18 February 2006 - 09:37 AM in Lights, Strobes, and Lighting Technique

Hi,

I'm looking for a cheapo strobe after falling on 2 epoques ds150 which stopped working after 15 dives (no flood guaranteed :) ).

The Bonica seems fabulous - the neon head goes for 100 USD at B&H. Does anybody know if the screw is the same size as the epoque's ? That way I can re-use my existing tray and arm.

The Bonica XP seems to bring something like TTL - how on earth does that work with no communication between the strobe and the camera? At best I can understand that the strobes reads the distance - but that simply means that each time I change aperture I have a problem... Seems like a headache producer more than a feature :lol:
Any experience on that?

Otherwise I'm open to any other cheap recommendation. BTW - I use a Canon S50 underwater which I highly recommend!

BF_12060b.jpg



#80443 Fiber Optic for Bonica Strobe

Posted by xberg on 18 February 2006 - 09:22 AM in Lights, Strobes, and Lighting Technique

Vlad,

I would be interested in seeing that setup as well as I am also thinking of getting the cheap Bonica with my Canon S50 (the epoque DS150 died on me twice!)

That aluminium foil - do you put it in or outside the housing?

Thanks!



#80440 Epoque DS150 will not fire

Posted by xberg on 18 February 2006 - 09:16 AM in Lights, Strobes, and Lighting Technique

Julian,

I don't use both strobes at the same time :) I first had the problem with a strobe, then changed it. After 10 dives I had the same problem with the second strobe. Both strobes were new.

I use the Canon S50 - a splendid digicam with full maual controls, incl. pre-flash or not and 1st or 2nd curtain sync.

Anyway the problem does not come from the camera as my second strobe does not fire at all anymore...

Looking into another brand right now - will post my query in minutes.

Thanks!



#80151 Epoque DS150 will not fire

Posted by xberg on 16 February 2006 - 01:03 AM in Lights, Strobes, and Lighting Technique

Hi,

I own the Epoque DS150 strobe. After about 10 dives it stopped firing - it still was charging correctly, but simply was not firing when my digicam's strobe fired. At first it only fired at the very lowest setting (GN3), but then not at all.

I had it changed for another DS150.

That one worked fine for another 5 dives and then the same problem happened again - but this time worse, at it simply does not fire at all, even at GN3.

I don't believe it has ever flooded - the battery compartment looks super dry.

I can't change it again - do you know of anywhere in Europe where I could service the strobe? Otherwise any recommendation for a cheap - and RELIABLE strobe?

thanks!