Jump to content


Photo
- - - - -

Sea & Sea YS-D2 flash tube broken, common problem?

Sea & Sea YS-D2

  • Please log in to reply
18 replies to this topic

#1 kstokell

kstokell

    Lionfish

  • Member
  • PipPip
  • 72 posts
  • Gender:Male

Posted 15 June 2017 - 01:08 PM

My Sea & Sea YS-D2 flash tube has just broken! The unit is only 15 months old, and has done about 300 dives, when I checked my gear pre-dive today I noticed that one of my two strobes no longer worked. On closer examination I found that the flash tube in one strobe was just a pile of powder inside the housing, is this normal after such a short time?

 

I have just switched from mainly macro work using TTL, to wide angle shots where I use manual mode and generally more strobe power, could this have something to do with the problem?

 

Can anyone help me with the following questions:

 

- how/where do I get the strobe repaired (I live on a Caribbean island)

- any idea how much it costs

- I have a spare YS-D1 which I intend to use as a backup do I need to change any settings in either TTL or manual mode to factor in the D2/D1 mismatch (camera is an OMD-EM1)

 

Thanks in advance guys :-)!



#2 elanarchist

elanarchist

    Hermit Crab

  • Member
  • Pip
  • 4 posts

Posted 30 June 2017 - 02:21 PM

Hey did you have any luck?  I have a YS-D1 with a burst flash tube, looking for help on repair / parts.. thanks!



#3 kstokell

kstokell

    Lionfish

  • Member
  • PipPip
  • 72 posts
  • Gender:Male

Posted 02 July 2017 - 05:58 AM

Looks like I'm going to get mine replaced under warranty!



#4 Jak Crow

Jak Crow

    Triggerfish

  • Member
  • Pip
  • 32 posts
  • Gender:Male
  • Location:Livermore, CA
  • Interests:Scuba diving, underwater photography, wildlife photography

Posted 24 July 2017 - 10:12 AM

My YS-D2 burst its bulb in during a trip last September, right after the warranty was up. Backscatter did some testing and it turns out something was wrong with the strobe's system where it was dumping full output into the bulb, so a replacing the bulb would just eventually end up bursting again. Backscatter is pushing Sea & Sea to do a replacement because they've had a number of other customers with D2s that have failed right after warranty. Between this and my bad experience with 2 D1s, I'm really disappointed with Sea & Sea right now.


Please check out my photo gallery -

http://gallery.mom-is-a-terrorist.com


#5 Architeuthis

Architeuthis

    Wolf Eel

  • Member
  • PipPip
  • 198 posts
  • Gender:Male
  • Location:Austria
  • Interests:Diving / Photograpy / Video / Gardening / Cooking / Handcraft

Posted 07 September 2017 - 08:50 AM

I only can add another problematic YS-D2 case: I bougth two of them few weeks ago and after approx. 30 dives one of them looks as in the foto attached. It still works, but presumably at lower output.

The only ray of hope is, that my dealer ("Unterwasserkamera" in Vienna) says it is under warranty and I will get it repaired...

 

Wolfgang :(

Attached Images

  • P9040184.jpg


#6 maelstrom

maelstrom

    Moray Eel

  • Member
  • PipPip
  • 84 posts
  • Gender:Male
  • Location:Washington state, USA
  • Interests:Diving, cycling, photography

Posted 11 September 2017 - 09:29 PM

Mine died after 15 dives.  Unfortunately I was not diving much and was out of warrantee.  It cannot be repaired in the USA.   My Inons are back in service, albeit with reduced output after 10 years of heavy use.  Reduced output is better than no output. 



#7 Deinonych

Deinonych

    Sea Nettle

  • Member
  • Pip
  • 11 posts
  • Gender:Male
  • Location:Austin, TX
  • Interests:SCUBA Diving, Landscape Photography, Underwater Photography, Amateur Astronomy, Hiking

Posted 24 November 2017 - 07:41 AM

One of mine flooded earlier this year (the strobe housing itself, not the battery compartment).  Sea & Sea eventually replaced it under warranty with a new YS-D2J, but it took them nearly 4 months to do so.  The unit had to be shipped to Japan for "diagnosis."  Not sure why it took so long, but at least I didn't have to pay for repairs.  It seems there are a lot of issues with these strobes.



#8 Architeuthis

Architeuthis

    Wolf Eel

  • Member
  • PipPip
  • 198 posts
  • Gender:Male
  • Location:Austria
  • Interests:Diving / Photograpy / Video / Gardening / Cooking / Handcraft

Posted 12 December 2017 - 12:52 AM

Hi,

 

This is just an update to my "YS-D2 broken flashtube case":

 

Yesterday (Dec. 11st) I got my flash back. It works and it looks to me that it is a new unit, there are no signs of use (calk, corrosion). It is a black unit. Repair was under warranty, just postage (The dealer, "unterwasserkamera.at", did everything right). The flash was out for repair for 13 weeks, so the recent 2 week trip to Egypt was "the one strobe challenge" (but what shalls :mellow:, it was good anyhow ...).

My wife and me together have three YS-D2's in the household and unless another unit breaks in the near future it is more likely that we will acquire a fourth unit than that we will change to another brand - But in case someone is buying new flashes, I cannont recommend this brand any more, I rather would go with Retra or Inon...

 

Wolfgang

P.S.: I use the flashes almost exclusively manually and changed my habits a little: For WA, when a lot of power is neede, I use them only in the second brigthest setting and change to setting to "32" in exceptional cases and for few flashes only, hopefully this will help...



#9 Architeuthis

Architeuthis

    Wolf Eel

  • Member
  • PipPip
  • 198 posts
  • Gender:Male
  • Location:Austria
  • Interests:Diving / Photograpy / Video / Gardening / Cooking / Handcraft

Posted 29 January 2019 - 12:21 PM

I am saddend to add another chapter to the Sea & Sea YS-D2 problem tread:

 

Not even a year after the broken flashtube incident (see above) another YS-D2 flash (out of three, we have them since two years) exerted a problem: unreliable on/off switch, sometime it works, sometimes not - since September 2018. I sent it via my dealer (unterwasserkamera.at) in hope for repair. Just today, after monthes of nothing (January 29th 2019) I got a note from my dealer that, according to Sea & Sea repair center the damage is due to water inbreak into the battery compartment. Total loss, more or less, no warranty they offer to buy a new unit, 150 Euro off the new price.

 

=> Never a water inbreak to the battery compartment happened, not even a single droplet - so the Sea & Sea service department is just bumblers or, even more severe, deceivers.

=> Not to mention monthes w/o flash tube - already had a "one strobe challenge" on 2 week diving vacation upon the first disaster (certainly a good way to improve my fotografical skills :nea: )

 

Already after the first incident I intended to switch the strobe supplyer, but now I am 110% confident and ordered a Inon Z330 - hopefully Inon builds quality products and not this kind of "disposable" strobes as Sea & Sea does...

=> No way to continue with Sea & Sea strobes, even if they gave them for free...

 

Wolfgang


Edited by Architeuthis, 29 January 2019 - 12:41 PM.


#10 Edwin Westenberg

Edwin Westenberg

    Starfish

  • Member
  • Pip
  • 9 posts

Posted 29 January 2019 - 01:06 PM

Welcome to the club Wolfgang :(
I also had a strobe with an exploded flashtube and 1 strobe with exactly the same problems you described. They told me that the strobe was total loss and it was an users fault. There was water inbreak to the magnetic on/off switch compartment,it was not covered under warrenty. I cleaned the switch and it works again! I will never buy a Sea&Sea product again and especially nothing by those idiots that declared the strobe total loss. (Sea&Sea Netherlands and Onderwaterhuis who did a second opinion)

#11 kyzy23

kyzy23

    Sea Nettle

  • Member
  • Pip
  • 13 posts

Posted 12 February 2019 - 08:15 PM

Yes, the stories continue. I have had all of these issues. The first one it was the front factory seal that leaked and the strobe exploded underwater. Just a pop and it looked just like that picture in this tread. Sea and Sea gave me a new one. My second strobe leaked but no explosion. It was out of warrantee but I only ended up paying 1/2 for a new one. The third one did exactly what was explained in this tread with the bulb breaking for the same reason. It occured during the change over back to the Japan manufacturer. There was a long wait. Sea and Sea replaced a panel that would be capable of handling the extra heat and no more problems. Also a new bulb was installed. It may be years before Sea and Sea can fully recuperate from these manufacturer errors. It is hard to forget an expensive vacation going down the tubes because of faulty equipment. I now ALWAYS travel with 3 strobes and was covered in all 3 incidents. Backscatter saw me through it all - even came to my rescue before I carried 3 strobes, and personally delivered a new strobe to me when mine blew up two days before my departure of a trip. It is best to work with your "camera dealer". Anything that you experience with the strobe they have already had many go through their shop. There is a running record of the same type of issues with these YS D2's. Now that they are back in Japan, the incident rate has improved so don't give up on them. Future purchases should be checked - make sure they are YS D2J - also YELLOW only. Since I now have 4 YS D2's I am sticking with them for awhile - however, the new Retras sure look pretty to me these days!!!  


Edited by kyzy23, 12 February 2019 - 08:22 PM.


#12 Vagabond

Vagabond

    Triggerfish

  • Member
  • Pip
  • 39 posts
  • Gender:Male
  • Location:Cape Town

Posted 22 February 2019 - 06:31 AM

All, looks like I am experiencing the same problems.  At first I had two YS-d1 that failed, nothing could seemed broken from the outside on the same dive, no show of water ingress, when sent back to dealer and on to Sea and Sea, user error, water ingress - I don't believe it.   Bought two YS-d2, one of my Ys-d2 flash tube fragmented yesterday with no apparent issue, water or anything.  Ship it and attempt to repair will cost more than a new strobe, so here you go.  The only thing we can do is to no longer purchase Sea & Sea.  If someone knows where I could get my hands on a flash tube I would attempt to fix it myself.  Thank you.



#13 JMartel

JMartel

    Lionfish

  • Member
  • PipPip
  • 53 posts
  • Gender:Male
  • Location:Seattle, WA

Posted 25 February 2019 - 08:49 AM

I regret buying my YS-D2 strobes. Bought one very slightly used (i.e. no warranty), and one new. The new one was messed up upon arrival. It would flash itself every few seconds while underwater with no provoking. Bluewater replaced that one for me. The replacement for that ended up with the burnt flash tube like in this thread like 6 months later. That one was replaced with the D2J yellow version. Now the first D2 that I bought (the not truly new one) no longer changes output strength when I turn the dial. Stuck in one setting only. Was fine for 2 years and now this. My dive buddy had a YS-01 fail on her as well. Wouldn't fire and perpetually charging the capacitor while getting hot.

 

Don't buy from Sea & Sea. Retra or Inon only at this point.



#14 Architeuthis

Architeuthis

    Wolf Eel

  • Member
  • PipPip
  • 198 posts
  • Gender:Male
  • Location:Austria
  • Interests:Diving / Photograpy / Video / Gardening / Cooking / Handcraft

Posted 06 March 2019 - 02:22 AM

Another incident with Sea&Sea YS-D2 strobes:

 

I returned last week (February 28th, 2019) from a two week trip to the Red Sea. During the trip I overheated another one of the strobes - not much, only a small spot on the front plastic, and fortunately it still works.

And this although I operate these strobes only at most at half power routinely for WA (meaning LZ16 and this for a relatively bulky and expensive strobe). Only on exceptional occasions I dare to use maximal power for a single shot...

 

My overall bilance so far:

Three YS-D2 for three years usage (maybe 70-80 dives/year): #1.: No. 1 burned out completely (replaced under warranty), #2.: Second one stopped working (warranty denied by service in Netherlands, they say it was because flooding the battery compartment - but such flooding, even not a single drop of water, never occured!), #3.: Third one was close to breaking, now has a dent, but still working (for how long?)...

 

I switch now to Inon Z330 (one was already with us in Egypt, a second one just ordered now) - hopefully these are not the same junk...

 

Wolfgang


Edited by Architeuthis, 06 March 2019 - 04:32 AM.


#15 TimG

TimG

    Sperm Whale

  • Moderator
  • 2392 posts
  • Gender:Male
  • Location:Amsterdam
  • Interests:Sunlight reefs, warm seas, good food and fine wine. And Manchester City Football Club.

Posted 06 March 2019 - 04:33 AM

Wow, that's pretty grim, Wolfgang. I'm really sorry.

 

If it's any consolation, I've been using Inons for 10+ years and have never had a problem with any of the 5 I have owned (knocking on wood!). I hope you have a  better time with the Z330.


Tim
(PADI IDC Staff Instructor and former Dive Manager, KBR Lembeh Straits)
Nikon D500, Nikkors 105mm and 8-15mm, Tokina 10-17mm,  Subal housing

http://www.timsimages.uk
Latest images: http://www.shutterst...lery_id=1940957


#16 drywh

drywh

    Triggerfish

  • Member
  • Pip
  • 33 posts
  • Gender:Male
  • Location:Hongkong

Posted 09 March 2019 - 12:37 AM

This is caused by poor heat dissipation. this is a land strobe.its Lamp tube surface has chapped and aged.But it never burned,never broken.Because the land flash has a zoom structure, it has a large gap around Lamp tube reflector.But the underwater strobe tube is sealed around.
 

 

微信图片_20190309155236.jpg



#17 JMartel

JMartel

    Lionfish

  • Member
  • PipPip
  • 53 posts
  • Gender:Male
  • Location:Seattle, WA

Posted 11 March 2019 - 07:22 AM

Sea & Sea also has no customer service to speak of as well. I contacted them several times about my recent strobe failure and haven't heard anything back. Not happy with them at all. Save your money and buy different ones. Maybe they will learn when people stop buying their crappy products.



#18 Balage_diver

Balage_diver

    Triggerfish

  • Member
  • Pip
  • 49 posts
  • Gender:Male
  • Location:Hungary
  • Interests:Underwater photo and electronics

Posted 25 March 2019 - 07:51 AM

Im join the club.  :(    I have a robbed tube D2 old  and the second has electrical problem.     :(   Nobody answerd any mail from Sea and Sea!  But we would like to repair those.

 

After i bought a new D2J and tested that.  The results is frustrating.  The strobe does not work under 1/64. The sensor is very very poor quality.

The second problem:  

If there are two prefelash in the expo , (Oly, or Nikon) the strobe signed the expo was correct but the 3rd flashing is not work because the expo was done with the second preflash and the strobe goes standby. :(

Does anybody has same situation?

Balazs..


TTL for all strobe....   TURTE TTL TRIGGER


#19 LeafySeaDragon

LeafySeaDragon

    Sea Nettle

  • Member
  • Pip
  • 13 posts

Posted 27 April 2019 - 03:01 PM

After having a YS-D2 replaced for not turning on, the replacement YS-D2J has now exploded. Yes, the Version manufactured in Japan. The strobe was on at the time but not being fired. Theres absolutely not a drop of water in the battery compartment. Has anyone else had this problem with the new YS-D2Js? Its such a pity as theyre a good strobe to use40358311-A89A-4E55-9D67-3AC7636D9462.jpeg





Also tagged with one or more of these keywords: Sea & Sea YS-D2