Jump to content

- - - - -

Canon lens problem

  • Please log in to reply
12 replies to this topic

#1 habbadog


    Brine Shrimp

  • Member
  • Pip
  • 1 posts

Posted 30 July 2006 - 10:55 PM

I am using a canon eos 350D (rebel XT) with a Canon 100mm macro lens in an Ikelite housing. I am using Ikelite strobes (DS50+DS125) and I have a problem when using the macro lens.
When I am taking picture underwater I sometimes have a problem of the lens stops talking to the housing and the apeture appears as 'OO' in the viewfinder.
Has anyone else has this problem, and if so, is it curable?
Dave Chillari

#2 mattdiver


    Tiger Shark

  • Member
  • PipPipPipPip
  • 698 posts
  • Location:Singapore
  • Interests:Photography (duh!), billiards, modern architecture.

Posted 31 July 2006 - 01:44 AM

I'm not a Canon user, but a similar thing sometimes happens on Nikon CPU lenses. If the aperture ring is not physically set onto F22, the camera displays FEE insteadof the aperture, and cannot communicate with the lens to make adjustments to the aperture. I seem to recall a thread where this was discussed. Do you use a manual focus ring? If so, make sure it is properly fixed and doesn't nudge the aperture ring when you operate it.

#3 james


    The Engineer

  • Super Mod
  • 9969 posts
  • Location:Houston TX

Posted 31 July 2006 - 05:25 AM


Thanks for helping Matt. THe 100mm USM lens doesn't have an aperture ring, however this error occurs when all of the electrical contacts on the lens aren't making good contact w/ the camera. This can happen if the contacts are dirty, or if the camera/housing is putting sideways pressure on the lens.

Canon 1DsMkIII - Seacam Housing
Dual Ikelite Strobes
Photo site - www.reefpix.org

#4 Rattus


    Sting Ray

  • Member
  • PipPipPip
  • 293 posts
  • Location:Cambridge UK

Posted 31 July 2006 - 07:17 AM

What James says. It's usually caused by faulty or dirty contacts on the lens or the mount.

Firstly try cleaning the contacts on the back of the lens using a (if possible) a contact cleaner pen. Theses are like dry (no ink) fibre tipped pens. otherwise try a lens tissue or microfibre cloth. Make sure the gold contacts are nice and clean. Also check that the corresponding contact pins on the lens mount of the camera body are clean and operate correctly. They are spring loaded to make proper contact, but this spring loaded action can get sticky sometimes. Try gently pushing each pin with your finger nail to make sure they push in freely and don't snag.

Good luck,

Canon 5D
S&S DX-5D housing, TTL, YS-110s, ULCS, etc.

#5 betti154


    Eagle Ray

  • Member
  • PipPipPip
  • 344 posts
  • Gender:Male
  • Location:Sydney, Australia

Posted 03 August 2006 - 12:57 AM

I too have the 350D, Canon 60mm and 100mm lenses. I have the 00 aperture problem occur on maybe 2-3 seperate occasions in 150+ dives.

The 350D manual says error 00 means no lens or incorrectly fitted lens. The manual says the fix is to remove and re-fit the lens. This fixes the problem but doesn't help you underwater.

To avoid the problem I do the following:

1. Ensure the contacts are clean and the lens is mounted in firmly. I turn it back the other way too to ensure that it is locked in.
2. Take a 1-2 shots was assembled to ensure that aperture can be adjusted, CF card is in, and strobes are firing correctly.

Simples things but they seem to help in avoiding simple problems.

Damien Siviero
Canon 5DmkIII + 7D. Aquatica Housing. Ikelite + Inon Strobes. Canon + Tokina Glass.

#6 Rai



  • Member
  • Pip
  • 43 posts
  • Location:Mataró - Spain

Posted 26 September 2006 - 05:47 AM

I've experienced the same problem all this summer, specially with the Canon 100 mm but also with the 60 mm and even with the Sigma 15 mm FE.
Sometimes the problem apppears as an "Err 00", implying a dirty contact problem, specially with the 15 mm failures. But mostly it doesn't show any error message: it only shows a 00 aperture value and the camera gets fully locked :blush: . Obviously, the lens was properly fitted in all the cases.

Cleaning the contacts with an appropiate pen didn't solve the problem completely. But when using a ear cleaner with alcohol the result was more efective: The 15mm didn't lock again, the 60 mm barely did it, but the 100 mm continued in erratic failures :blush: .

My workaround with the 60 mm was to reset the camera and worked the few las times it happened. With the 100 mm the camera reset didn't work, but moving the mode dial from M (the mode I use) trough the basics modes and then again to M mode worked (at least for me). But it also made me lose many big oportunities.

My bet goes for a moisture/condensation problem, based on the erratic behaviour and the cleaning with alcohol impact in the event frequency.


Edited by Rai, 26 September 2006 - 05:59 AM.

#7 Notorious



  • Member
  • PipPip
  • 59 posts
  • Location:Perth, Australia

Posted 26 September 2006 - 06:48 AM

I had this problem while away on a trip. The lens was nearly new and the lens contacts seemed clean. I tried cleaning them with cotton buds and a tissue, I had no solvent. The 00 error wouldnt go away. Sombody sugested I use the eraser on the back of a pencil! I did this and afterwards the eraser was covered in black gunk! The problem went away and never returned. I think the grease build up wasnt helped by the very high humidity.
00 error = dirty contacts. If you think you have cleaned them or they look clean. Clean them again, properly
Canon 350D:Sigma 10-20mm:Magic filter:Sea&sea housing:Athena dome:

#8 steve-k



  • Member
  • Pip
  • 15 posts

Posted 26 September 2006 - 08:01 AM

had a similar problem, but comes up error 99 (on the 20-d)
supposed to be dirty contacts as well,
only had the problem on the 18-55 kit lens

on my searching for the problem it said clean with a rubber (ink) more abrasive than your suggestions

this just a canon fault?

#9 steph



  • Member
  • Pip
  • 26 posts
  • Gender:Male
  • Location:Grenoble, France

Posted 26 September 2006 - 11:37 AM


I have had the err 99 problem with the sigma 50mm macro when using it wide open (f2.8)
on 20D when using it behind eTTL converter. (in manual or with no flash it works).

What ever I do, this combo freeze the camera to err 99. The only way to clear it, is to
remove the battery.

However, the only time it occured was when testing the converter on land.
So this is not a problem as I never use this aperture underwater for macro.


What all this told us, is that digital camera are full of software and all devices you plug on
it (flashs, lenses) the camera tries to communicate with these elements (at prime to guess
what it is).
Plenty of elements means plenty of test cases and behind that... potential bugs.


Nikon D300, Subal housing, GS180, WS45, 8" Subal dome, 4" Zen dome, Subtronic, Inon.
My website : http://www.stephanesandon.com

#10 Rai



  • Member
  • Pip
  • 43 posts
  • Location:Mataró - Spain

Posted 27 September 2006 - 12:04 AM

Just for giving a more complete view of my camera-lock scenario.

It only happened to me when the camera is in the Ikelite housing, but I discard problems with the built-in eTTL converter becuase I switched off the flash/flashes as first checks and after trying any combination posible and, in my case, I didn't find any relation with the failure (or getting back the camera working properly).

#11 jams


    Sea Nettle

  • Member
  • Pip
  • 14 posts
  • Location:Vancouver BC / Around S.E. Asia

Posted 27 September 2006 - 05:42 PM

My 2 cents: (on- and slightly off- topic)

I purchased an EOS 5D from Singapore back in June and with it the 100mm Macro USM and the 17-40 USM lenses. Recently I went on a trip up an active volcano in Java and stupidly changed lenses a couple of times in the dusty air (I can't afford 2 bodies). When I got back, I cleaned off all the equipment outside and in, and went and took a bunch of photos at a local ceremony. After about 100 shots, with the 17-40 lens still attached to the body, it suddenly stopped communicating with the body and I got error '00' codes showing up and a failure to lock focus. No such problems with the 100mm. I tried cleaning all the contacts, but this didn't seem to have much effect.

Luckily, I was going back to Singapore that week and ran everything straight to the Canon office there for a pro service and cleaning. Service was fantastic, they did it all in less than a day for me (I was only in town for 36hrs) and I paid only a nominal fee for the express service. I haven't had any problems with it since. They didn't tell me that anything specifically bad had happened to the lens, so I can only presume they cleaned it in a way I wasn't able to.

Bottom line, I guess (as they didn't charge me for a service - it was under warranty) is that if you treat your equipment well and clean the things you can safely clean and the equipment still doesn't work as it's supposed to, then it becomes the manufacturer's problem, so take it in for a repair/service. In this day and age, when our equipment is so internally complicated and delicate a regular servicing is worth it's weight in gold/missed shots. And I must say again that I was very impressed with Canon's service, especially as I was the one who'd put the camera in jeopardy and so I was expecting them to be difficult about it.

Sorry about the slight wander off-topic...


#12 peterv



  • Member
  • Pip
  • 23 posts
  • Location:Knee-deep in Tampa Bay, Florida
  • Interests:Diving, Biomedical stuff

Posted 09 December 2006 - 09:37 AM

If you have contact problems with lenses, strobes, cables, battery contacts, etc.
try DeOxIt or DeOxIt Gold (Caig Laboratories).
Use the little pen-tip dispenser.

#13 baddpix



  • Member
  • Pip
  • 41 posts
  • Location:Perth, Western Australia

Posted 31 January 2007 - 12:32 AM

I am using a canon eos 350D (rebel XT) with a Canon 100mm macro lens in an Ikelite housing. I am using Ikelite strobes (DS50+DS125) and I have a problem when using the macro lens.
When I am taking picture underwater I sometimes have a problem of the lens stops talking to the housing and the apeture appears as 'OO' in the viewfinder.
Has anyone else has this problem, and if so, is it curable?
Dave Chillari

I have had this problem several times and I think I've got it under control.

Apart from dirty contacts, other possible causes are:
  • wet contacts, caused by condensation in the housing. To avoid this, do the usual stuff - put some dessicant inside the housing. Assemble the housing in advance of the dive, so that the dessicant has time to work. Don't allow the camera to heat up in the sun. etc
  • accidentally depressing the lens release. On the Ikelite SLR housings for Canon 20D and 350D etc, there is a small lever on the left side (below the large knob for the zoom gears) that is used to depress the `depth of field preview' button on the camera. The lever is also designed to be rotated through 180 degrees to engage with the lens release button on the camera body, so that you can change lenses after opening the front lens port. When you assemble the housing, make sure that the lever is not waving around inside the housing near the lens release button! Otherwise when you descend at the start of a dive, the increasing pressure may force the end of the lever to gently depress the lens release button, and hey presto, no communication with the lens. :) If you get Aperture 00 during a dive, or if the camera ceases to respond to everything except on/off switch, my suggestion is to try gently rotating the lever AWAY from the camera body. It's worked for me several times.

Canon 20D, Ikelite, DS-125, 18-55mm, 17-85mm, 10-22mm, 100 mm, Woody's, Magic, NightSea
"Got the gear - but no idea" My Webpage