Jump to content


Photo
- - - - -

Windows users: don't update to iTunes 7


  • Please log in to reply
9 replies to this topic

#1 echeng

echeng

    The Blue

  • Admin
  • 5844 posts
  • Gender:Male
  • Location:San Francisco, CA
  • Interests:photography, ice cream, cello, chamber music, quadcopters

Posted 14 September 2006 - 09:42 AM

A warning: Windows users shouldn't upgrade to iTunes 7 yet. I did, and I can no longer play video. Reproduced from my online journal:

It is absolutely incredible. iTunes for Windows keeps on getting worse! (read my old rant) The UI improvements in iTunes 7 are welcome, but I just tried playing a 320—240 downloaded podcast, and it totally takes down my 2Ghz Core Duo IBM Thinkpad T60p. Incredible.

UPDATE: this seems to be specific to certain Windows machines -- some play video just fine.

In the little integrated video window, the podcast is choppy. Heaven forbid that you€™d want to click on the video to bring it up in its own window. At default size, podcasts run at 2 frames per second, and audio filters in and out. I would have been really embarrassed to release a software product so crappy.

An anonymous iTunes development team member replied, €œuse the Mac version,€ when I brought up the extreme shittiness of the Windows version. Nice. :blink:

I work-around is to use Quicktime to play podcasts and other videos instead of iTunes.

The Mac version seems to work fine.
eric cheng
publisher/editor, wetpixel
www | journal | photos


#2 segal3

segal3

    Powerful Sea Gull

  • Admin
  • 1739 posts
  • Gender:Male
  • Location:Los Angeles, CA

Posted 14 September 2006 - 10:55 AM

I upgraded last night prior to watching the most recent DiveFilm Video Podcast by Wags and Kelly, and had no issues. (P4 3.2GHz)

Not sure what the problem is on your end, Eric :blink:
Matt Segal - carbonos scuba

#3 echeng

echeng

    The Blue

  • Admin
  • 5844 posts
  • Gender:Male
  • Location:San Francisco, CA
  • Interests:photography, ice cream, cello, chamber music, quadcopters

Posted 14 September 2006 - 11:06 AM

Interesting. Maybe they've patched it already. I'm on a Core Duo notebook over here. Others have also complained about Windows playback. Maybe I'll give it a try on my desktop Windows machine.
eric cheng
publisher/editor, wetpixel
www | journal | photos


#4 echeng

echeng

    The Blue

  • Admin
  • 5844 posts
  • Gender:Male
  • Location:San Francisco, CA
  • Interests:photography, ice cream, cello, chamber music, quadcopters

Posted 14 September 2006 - 11:17 AM

You're right. It does play fine on my desktop machine.

I'll amend this post to say that you should be wary of the upgrade, as it may not work well on all machines!
eric cheng
publisher/editor, wetpixel
www | journal | photos


#5 JackConnick

JackConnick

    Orca

  • Industry
  • PipPipPipPipPip
  • 1253 posts
  • Gender:Male
  • Location:Seattle, WA
  • Interests:Sailing, diving, women, cats

Posted 14 September 2006 - 12:13 PM

There was also a new update to Q.T. that was released at the same time. You might want to make suer that was installed ok.

Jack

Jack Connick
Optical Ocean Sales.com Sea & Sea, Olympus, Ikelite, Athena, Zen, Fix, Nauticam, Aquatica, Seacam, Gates, 10Bar, Light & Motion, iTorch/I-DAS & Fantasea Line - Cameras, Housings, Strobes, Arms, Trays & Accessories
Blog & Gallery: Optical Ocean Sales Blog
Flickr Gallerys: Optical Ocean on Flickr


#6 wagsy

wagsy

    Blue Whale

  • Senior Moderator
  • 3845 posts
  • Gender:Male
  • Location:Cairns, Queensland.
  • Interests:Sewing and Knitting......no diving of course :-)

Posted 14 September 2006 - 03:25 PM

Eric
I loaded it up on my PC and it seemed to work okay but It's gone now as I did a roll back last night. I'm like you and use other ways to retrieve them. There is podcast catching software and even on line HTML feeds you can just go to and click on to download.
Amphibico Phenom & EVO PRO & Navigator 900
Share Your Underwater Videos www.hdvunderwater.com | www.flykam.com.au | www.reeftorainforest.com.au

#7 madguppy

madguppy

    Triggerfish

  • Member
  • Pip
  • 34 posts
  • Location:Indian Harbour Beach, FL

Posted 14 September 2006 - 03:44 PM

There are still windows users?? how wierd!
John Paul Abramo
Staying wet behind the ears
http://web.mac.com/madguppy2

#8 echeng

echeng

    The Blue

  • Admin
  • 5844 posts
  • Gender:Male
  • Location:San Francisco, CA
  • Interests:photography, ice cream, cello, chamber music, quadcopters

Posted 14 September 2006 - 03:51 PM

There are still windows users?? how wierd!

According to browser stats from large organizations, in 2006 so far, 90% of people are using Windows OSes to browse the web. 3.6% Mac, 3.4% Linux.

So, yeah. There are still Windows users.
eric cheng
publisher/editor, wetpixel
www | journal | photos


#9 acroporas

acroporas

    Beach Bum

  • Critter Expert
  • 1776 posts
  • Location:Atlanta, Georgia

Posted 14 September 2006 - 05:26 PM

Where is the final 3% ?
William

Canon 5D Ikelite Housing and strobes
15FE | 24/2.8 | 35/1.4 | 85/1.8 | 150/2.8 macro

#10 herbko

herbko

    Herbzilla

  • Super Mod
  • 2128 posts
  • Gender:Male
  • Location:Northern California

Posted 14 September 2006 - 05:32 PM

Where is the final 3% ?


Probably other Unix OS (Sun, HP,BSD,....). If you lump those with linux Mac's are third.
Herb Ko http://herbko.net
Canon 5D; Aquatica housing; 2 Inon Z220 strobes; Canon 100mm macro, 17-40mm ; Sigma 15mm FE, 24mm macro, 50mm macro