Jump to content


Photo
- - - - -

Adobe Lightroom 2.3


  • Please log in to reply
7 replies to this topic

#1 photovan

photovan

    Great White

  • Moderator
  • 979 posts
  • Gender:Male
  • Location:Brisbane, Australia

Posted 03 March 2009 - 07:37 AM

Here's the links to the Lightroom 2.3 Updates
for mac
for Windows

Adobe says
• Additional camera support for the Nikon D3X and the Olympus E-30
• Several corrections for issues introduced by the Lightroom 2.0 release

Darren Jew  |  Australia  |  darrenjew.com  |  fotofrenzy.com.au

Canon EOS1Dx   |   EOSM   |   Nauticam  |   Inon Z240


#2 jeremypayne

jeremypayne

    Great White

  • Member
  • PipPipPipPip
  • 1199 posts
  • Gender:Male
  • Location:New York City

Posted 03 March 2009 - 07:42 AM

I've been using LR 2.3 RC for some time and find it to be very stable.

I skipped 2.2 because of serious 64-bit version memory issues.
Jeremy Payne
My Website

#3 Steve Williams

Steve Williams

    Humpback Whale

  • Moderator
  • 3022 posts
  • Gender:Male
  • Location:Tucson, Arizona
  • Interests:Protecting our Ocean, Environmental Education,
    Having fun and Living Well

Posted 03 March 2009 - 07:52 AM

Thanks Darren, I've been not so patiently waiting for the fix.

"from the read me file"


Lightroom 2 Bugs - Fixed

• In the Windows 64-bit version of Lightroom an sFTP upload process could cause Lightroom to crash.

• Slideshows could return to the first image randomly during playback.

• A memory leak could cause Lightroom to crash while attempting to process files with local adjustments. :P Hooray!!!!

• Canon EOS 5D Mk II sRAW files could process with artifacts in Lightroom 2.2.

• Lightroom 2.2 could cause disc burning to fail for Windows customers.

• Attempting to undo(CTRL-Z) a single step in Lightroom 2.2 on Windows could cause a series of previous actions to be undone.

Glad to know it's working Jeremy!

Steve


The Fin Foundation
My Images on Flikr

Canon7D & 40D, 60mm, 100mm, 17-40L, Tokina 10-17, Nauticam 7D, Sea & Sea MDX-40D YS-250's ULCS arms, Lightroom


#4 photovan

photovan

    Great White

  • Moderator
  • 979 posts
  • Gender:Male
  • Location:Brisbane, Australia

Posted 03 March 2009 - 07:53 AM

yep, they are out of Adobe Labs – no longer "candidates", now a full releases.

Darren Jew  |  Australia  |  darrenjew.com  |  fotofrenzy.com.au

Canon EOS1Dx   |   EOSM   |   Nauticam  |   Inon Z240


#5 Scubamoose

Scubamoose

    Great White

  • Member
  • PipPipPipPip
  • 1118 posts
  • Gender:Male
  • Location:Estonia
  • Interests:Diving, photography, travel.

Posted 03 March 2009 - 08:00 AM

Probably the most stupid question of all, but im really not "home" with computers...
So if I update LR 2.2 to 2.3 then the isues Steve mentioned are taken care of? :P
Specially "A memory leak could cause Lightroom to crash while attempting to process files with local adjustments." - that I had problems with...?
My Flickr
www.karelbernard.com

Karel Bernard
Canon G9 in Ikelite Housing; SubStrobe DS-160
WA lens Ikelite W-20; Inon UCL-165 M67 Close-up Lenses

#6 photovan

photovan

    Great White

  • Moderator
  • 979 posts
  • Gender:Male
  • Location:Brisbane, Australia

Posted 03 March 2009 - 08:01 AM

Probably the most stupid question of all, but im really not "home" with computers...
So if I update LR 2.2 to 2.3 then the isues Steve mentioned are taken care of? :P
Specially "A memory leak could cause Lightroom to crash while attempting to process files with local adjustments." - that I had problems with...?

Yes, Adobe are saying those issues are fixed in the 2.3 release.

Darren Jew  |  Australia  |  darrenjew.com  |  fotofrenzy.com.au

Canon EOS1Dx   |   EOSM   |   Nauticam  |   Inon Z240


#7 Scubamoose

Scubamoose

    Great White

  • Member
  • PipPipPipPip
  • 1118 posts
  • Gender:Male
  • Location:Estonia
  • Interests:Diving, photography, travel.

Posted 03 March 2009 - 08:08 AM

Yes, Adobe are saying those issues are fixed in the 2.3 release.


Thanks Darren! :P
Will upgrade it ASAP!
My Flickr
www.karelbernard.com

Karel Bernard
Canon G9 in Ikelite Housing; SubStrobe DS-160
WA lens Ikelite W-20; Inon UCL-165 M67 Close-up Lenses

#8 dmoss

dmoss

    Sting Ray

  • Member
  • PipPipPip
  • 222 posts
  • Location:Too far from the ocean

Posted 11 March 2009 - 05:04 AM

An issue that I found very frustrating with LR was in the slideshow module where it would randomly jump back to the first slide. Discovered on some forum that this could be prevented by "rendering standard previews" before running the slideshow. Wasn't a problem with some machines, but it was for mine. One of the bug fixes that Adobe announced with 2.3 addressed this problem and my slideshows run fine now.

Edited by dmoss, 11 March 2009 - 05:08 AM.

David
Canon 5D, Ikelite


My Flickr Photos