Jump to content


Photo
- - - - -

Small WARNING for D80, Ikelite and B&H Photo


  • Please log in to reply
4 replies to this topic

#1 Grayscale

Grayscale

    Moray Eel

  • Member
  • PipPip
  • 77 posts

Posted 13 June 2010 - 01:26 AM

This might concern those of you who bought an Ikelite D80 from B&H photo.

B&H list the o-ring set 5512.68 as an accessory for the D80 housing. THIS IS WRONG
The 5512.68-set includes a port o-ring (#0105) that fits, but the body o-ring (#0132.59) is too small and is supposed to be used for the D70!
The o-ring #0132.61 will fit the D80 and is listed as an extra accessory, but is not in the o-ring set.

I bought two of those sets when I got my gear. And thankfully I've never needed to change o-ring.
It even took me a while to discover that it didn't fit, because when I got everything; I just checked I got all the parts I ordered, took the one supplied with the housing and stored the extra o-rings I bought in ziplock bags to use if/when needed. Really nice if I were to discover this when I actually would need them. Like out on a liveaboard...

You could think a well known company like B&H would get thier info straight.
I've contaced B&H about this and I'm waiting for their answer.

Now I've bought two of the correct o-rings from another store.

Grayscale

#2 henryp

henryp

    Brine Shrimp

  • Member
  • Pip
  • 1 posts
  • Location:New York, NY

Posted 13 June 2010 - 03:44 PM

Thanks for bringing this to our attention. We'll check this out and if correct we'll update our site ASAP.

#3 Don in Colorado

Don in Colorado

    Eagle Ray

  • Member
  • PipPipPip
  • 307 posts
  • Location:Fort Collins, CO

Posted 13 June 2010 - 10:17 PM

B&Hphoto is usually the best, and it appears they still are. Thanks for helping us and them.

Edited by Don in Colorado, 13 June 2010 - 10:17 PM.


#4 rtrski

rtrski

    Great White

  • Member
  • PipPipPipPip
  • 1001 posts
  • Gender:Male
  • Location:Texas, USA
  • Interests:Slowly learning digital photography and underwater digital photography. Like drinking from a salt-water firehose... ;-)

Posted 16 June 2010 - 06:28 PM

Wow, responded inside of 2 hours, on a weekend no less.

If it was an error, that's certainly classy in terms of responsiveness!

Current rig: Sony SLT-alpha55 in Ikelite housing, Sigma 105mm f2.8 DC Macro w/ Ike 5505.58 flat port or Sigma 8-16mm f/4.5-5.6 DC HSM behind UWCamStuff custom 5" mini-dome. Dual INON z240 Type IVs triggered with DS51 for TTL mimicry, or DS51 alone with home-made ringflash assy for macro.

 

Topside, unhoused: Sony SLT-alpha99, Sigma 150-500mm + 1.4TC (Saving for Sony 70-400 G2), Sigma 15mm diagonal fish, Sony 24-70mm f2.8 CZ, Tamron 180mm f2.8 Macro...all the gear and nary a clue...


#5 Grayscale

Grayscale

    Moray Eel

  • Member
  • PipPip
  • 77 posts

Posted 01 July 2012 - 04:46 AM

Wow, responded inside of 2 hours, on a weekend no less.

If it was an error, that's certainly classy in terms of responsiveness!




Just a small addition to this subject since I had a discussion about this type of things at home. It was actually 14 hours it took to answer that, not 2 hours. And I even mailed them almost 10 months earlier with an angry letter about this problem. Then they didn't care at all. I really wonder how some of the big stores think...