Jump to content


Photo
- - - - -

Broken bulkhead on Olympus PT-027


  • Please log in to reply
3 replies to this topic

#1 Gabi

Gabi

    Sea Wasp

  • Member
  • Pip
  • 2 posts

Posted 07 July 2010 - 05:16 AM

Hi all!

This is my first post to this forum, although I'm reading it for years... :notworthy:

I own an Olympus housing, PT-027, for my C-7070.

Last year, the buildhead connector broke. I managed to glue it back together with acrylic glue, and it held for a couple of dives.
Last week, I took the housing from the shelf, and was surprised to find out that the buldhead connector broke in two. The glue didn't fail, the plastic broke on the other side!

Now, I don't have a flash, nor planning to use one with this camera and/or housing, so I don't really need the connector, or plan on buying replacement connectors for hunderds of dollars.


Any idea with what can I safely seal the hole in the housing so I can get back to underwater photography ?



Thanks ahead,
Gabi

#2 altsaint

altsaint

    Clownfish

  • Member
  • Pip
  • 23 posts

Posted 07 July 2010 - 01:30 PM

I had one of these break on me last year. I have owned the housing since 2005 and am surprised it hadn't broken before, as it is just plastic.

In my case, I spent about 45 ( Sterling - I live in the UK ) on a replacement. I also recently bought a cheap replacement port from a dealer who was breaking one up for scrap.

I know this doesn't answer your question, as you just want a simple fix to seal the hole. But it may be for a reliable alternative you can buy a second-hand spare that won't cost $$$.

#3 whaleshark

whaleshark

    Triggerfish

  • Member
  • Pip
  • 33 posts
  • Gender:Male
  • Location:So Cal

Posted 14 July 2010 - 11:20 AM

Gabi,
How about posting a photo of the bulkhead?
I saw a repair for one of these on eBay last year. They used a bolt through the bulkhead with washers and o-rings on both sides. They added silicone glue for double protection. Find some stainless steel bolts, nuts and washers to fit and the right size, fat plumbing O-rings from your favorite hardware store and give it a try. The O-rings should fit the bolts closely and squish flat undeer the flat washers when the nuts are tightened, covering the hole and sealing around the bolt. Be sure to test the housing at depth without the camera before taking the camera in the water.
Dave

Edited by whaleshark, 14 July 2010 - 11:21 AM.

Dave in So Cal
Olympus E-3, E-330, C-8080, Olympus Zuiko Digital lenses: 7-14, 11-22, 14-54, 50 f/2, 50-200, Pan/Leica 25 mm f/1.4
Ikelite housing for C-8080 and E-330, dual Ikelite DS-125 strobes

#4 slowhands

slowhands

    Clownfish

  • Member
  • Pip
  • 25 posts

Posted 09 August 2010 - 03:37 AM

..
I own an Olympus housing, PT-027, for my C-7070... Last year, the buildhead connector broke. I managed to glue it back together with acrylic glue, and it held for a couple of dives. Last week, I took the housing from the shelf, and was surprised to find out that the buldhead connector broke in two. The glue didn't fail, the plastic broke on the other side!

Now, I don't have a flash, nor planning to use one with this camera and/or housing, so I don't really need the connector, or plan on buying replacement connectors for hunderds of dollars.

Thanks ahead,
Gabi


I had the same problem with my PT-027 years ago. One option is to rob one from another housing. There are a lot of PT-022s sitting around unused, cheap. It's the same part.

I lucked out. The good people at Reef Photo happened to have a replacement bulkhead in stock for $30. Give them a call at 877.453.8927.

Edited by slowhands, 09 August 2010 - 04:05 AM.