Jump to content


Photo
- - - - -

D7000- Tokina 10-17 Problem


  • Please log in to reply
4 replies to this topic

#1 TBAR John

TBAR John

    Hermit Crab

  • Member
  • Pip
  • 3 posts

Posted 24 September 2011 - 05:11 PM

Hi all ;-) Just wondering if anyone else has had or heard of this problem occuring. On fitting my tokina 10-17 the other week i went to take the usual test shots the night before the dive and on releasing the shutter the camera went into like a burst mode with the shutter trying to release, no image taken and err coming up on the display. I removed the lense, contacts looked good, so i tried again. Same result.Removed cards and battery to see if some sort of reset would occur, then tried again same story. Seeing that it was the weekend i couldn't contact the supplier till Monday. After talking to a friend he suggested removing the lense, facing the camera towards me and seeing if the mirror was raising and lowering properly. All seemed good. I fitted my Nikon 18-200 and tried some shots and presto everything worked fine. Fired off about 200 shots and thought problem solved. Wrong. Refitted the 10-17 the night before this weeks dive and as soon as i tried to shoot same prob. as before. I then started thinking that maybe an issue with the Tokina not being on speaking terms with the D7000 anymore so i tried putting the 18-200 on again but was still getting the same shutter issue and err coming up on the display. Starting to get very frustrated as the set up is only a few months old and has been working fine with all settings.
I also tried removing all user settings and setting up from scratch, no Joy, then this morning,Sunday, I tried the camera again with the Nikon lense and everything is working fine again, so I suspect the 10-17 but am not game to put it on again in case it screws the camera up. Any useful help would be much appreciated,
Cheers, John


#2 Stoo

Stoo

    Wolf Eel

  • Member
  • PipPip
  • 156 posts
  • Gender:Male

Posted 29 September 2011 - 04:12 PM

John, just going out on a limb, but I know with some lenses, if the aperture isn't set to f22 (or whatever the minimum stop is) the communication with the camera gets all wonky.

I'm probably wrong but it might be worth checking...

Good luck!

#3 Stewart L. Sy

Stewart L. Sy

    Great White

  • Industry
  • PipPipPipPip
  • 915 posts
  • Gender:Male
  • Location:Richmond, BC

Posted 29 September 2011 - 04:31 PM

Try cleaning the contacts of both lens and camera. If that doesn't work you may need to send the unit to Tokina to replace the aperture motor. That's what happened to mine last year and I couldn't use it for the whale sharks in Sogod Bay, luckily I had my 5dmk2 and the 16-35 as "back-up"

Stewart

www.stewartsy.com
SLS Photography, when your images matter....
Aquatica, Amphibico, TLC, ULCS (Philippines), Stix, iTorch, FIT, Magic Filter Dealer
Philippine Dive Trip Specialist


#4 TBAR John

TBAR John

    Hermit Crab

  • Member
  • Pip
  • 3 posts

Posted 02 October 2011 - 03:20 PM

Thanks for the replies guys ;-)
I had already given the contacts on the lense and camera a wipe over with a lense cloth but it didn't make a difference.
After contacting their warranty dept. their man suggested that I try cleaning the contacts with a plastic rubber.
I was pretty sceptical, but lo and behold it seems to have done the job!
I then changed back and forth between lenses a couple of times and everything still seems to be working ok. Now I just got to get back in the water !
Cheers, John


#5 Undertow

Undertow

    Manta Ray

  • Member
  • PipPipPip
  • 441 posts
  • Location:Bermuda

Posted 05 October 2011 - 11:37 AM

glad you solved your problem.

indeed lens wipes are not enough to clean contacts.

A pencil eraser is best and has solved many a lens/camera communication problem i've seen.

I've even had issues with mild corrosion build up on a speedlight contact that could not be cleaned wiht an eraser and needed scraping with either a finger nail or even a metal edge, albeit gently.

cheers,

Chris
D200, Aquatica, 10.5, sig 15, 12-24, 17-55, 60, 105
3x SB-105