Jump to content

- - - - -

RX-100 photos from today


  • Please log in to reply
2 replies to this topic

#1 Xanderwater


    Moray Eel

  • Member
  • PipPip
  • 78 posts
  • Gender:Male

Posted 12 October 2012 - 05:07 AM

Hi everyone,

I bought a Sony RX-100 and Nauticam housing a few days ago, as a replacement for my Canon S95 in Ikelite housing.

Here are some shots of a dive(freedive) in the estuary in Perth Western Australia today.
I used a FIX UWL-04 fisheye lens, which had a tiny bit of vignetting, and 2x INON UCL-165M67 for the sea horse, which seemed to have soft corners but was ok in the center.

Photos are Jpg's from the camera, with only minor 'levels' adjustments in Photoshop. I still have to sort out a Raw converter.
I am very impressed with the crazy amount of detail, see the 100% crops.
Flash recharge took noticeably longer than my S95.

Cheers, Xander






Posted Image
New setup: Nauticam and Sony RX-100 by Xander Rood, on Flickr

Posted Image
RX-100 - 100% crop by Xander Rood, on Flickr


#2 Sfen



  • Member
  • Pip
  • 7 posts

Posted 16 October 2012 - 06:13 PM

did you use the camera flash or strobe?

you could adjust the flash level in the setting to reduce the flash recharge time....

#3 oskar


    Eagle Ray

  • Member
  • PipPipPip
  • 394 posts
  • Gender:Male
  • Location:Stockholm

Posted 18 October 2012 - 05:13 AM

I can't find any manual flash setting in the manual unfortunately.

Specifically on the RX100 recycle time, how bad is it?

Check out imaging resources review:


I quote from that (quite good) review:

Flash recycling was a significant shortcoming of the RX100, at 7.2 seconds from a full discharge. While not at all uncommon in small-body cameras with reasonable flash ranges, this is still a significant step down from what enthusiasts are accustomed to with either high-end (and bulky) point & shoots or interchangeable-lens cameras.

How bad is this in reality? I understand that if you have strobes in TTL mimic mode, the camera would not use up it's full power flash. However, I normally use them in pre-flash suppress mode and manual flash settings. I think this would mean maximum power each time, right? Anyone who have tested this yet?


Also tagged with one or more of these keywords: rx-100