Jump to content


Photo
- - - - -

Ikelite strobes with Nauticam housing


  • Please log in to reply
4 replies to this topic

#1 billywinter

billywinter

    Sea Nettle

  • Member
  • Pip
  • 13 posts

Posted 20 February 2013 - 09:34 AM

I just purchased a Nauticam housing for my 7D.  What's the easiest way to fire dual Ikelite 125's 

and also get TTL if possible?  I know they are not the most compatible strobes for this but that's

what I got.

 

 

Thanks

 



#2 marcw

marcw

    Wolf Eel

  • Member
  • PipPip
  • 140 posts
  • Gender:Male

Posted 20 February 2013 - 10:00 AM

did you read this:

http://www.ikelite.c..._pdf/4104_6.pdf

 

with this:

http://reefphoto.com...roducts_id=4640


Edited by marcw, 20 February 2013 - 10:02 AM.


#3 billywinter

billywinter

    Sea Nettle

  • Member
  • Pip
  • 13 posts

Posted 20 February 2013 - 12:33 PM

Thanks,  that's very helpful and not too pricey.  Do you know if you can connect the 2 ikelite strobes together

once you run the single cable to the bulkhead?



#4 Cerianthus

Cerianthus

    Tiger Shark

  • Member
  • PipPipPipPip
  • 655 posts
  • Gender:Male
  • Location:Hasselt, Overijssel, Netherlands

Posted 20 February 2013 - 10:17 PM

Don't know what the connector on the housing is, but the Ikelite cord listed is for FILM cameras and older strobes not the current series.
Gerard

My photo's on flickr
Crop the world ! (Using Canon 20D, 60mm, 100mm, 10-17mm FE, Ikelite)

#5 billywinter

billywinter

    Sea Nettle

  • Member
  • Pip
  • 13 posts

Posted 26 February 2013 - 02:09 PM

From what I've gathered, E-TTL can not be achieved with a Canon camera/Nauticam Housing & Ikelite strobes.  I

can install a Canon 6pin bulkhead into the housing and use an ikelite sync cord to fire the strobes, but It will have

to be set mannually.

 

Unless someone knows of an option??