Jump to content


Photo
- - - - -

Subal 1DS mk2 /w Sigma 15mm focus issue


  • Please log in to reply
2 replies to this topic

#1 betti154

betti154

    Eagle Ray

  • Member
  • PipPipPip
  • 342 posts
  • Gender:Male
  • Location:Sydney, Australia

Posted 02 July 2013 - 12:15 AM

Hi guys,

I'm posting this for a mate in the field. He's got a 1DS mk2 in subal housing, 9" port but no extension; and getting focus issues (ie can't lock).

I looked on the subal site but can't find the port extension recommendations, does anyone know the right extension (if any).

I've got a canon 28mm, 17-40mm and tokina 10-17mm I can send him tomorrow if either of those will work for him.

Thanks in advance, Damien


Damien Siviero
Canon 5DmkIII + 7D. Aquatica Housing. Ikelite + Inon Strobes. Canon + Tokina Glass.
http://damiensiviero.com

#2 betti154

betti154

    Eagle Ray

  • Member
  • PipPipPip
  • 342 posts
  • Gender:Male
  • Location:Sydney, Australia

Posted 02 July 2013 - 01:01 AM

Ok, I've got a real Internet connection and browser and the subal site is sort of useful to me now. it seems the 15mm extension is required with the Sigma 15mm (# EXR15). 

 

It also seems as though any of the lenses I could send him need an extension too, bugger. 

 

regards, ds


Damien Siviero
Canon 5DmkIII + 7D. Aquatica Housing. Ikelite + Inon Strobes. Canon + Tokina Glass.
http://damiensiviero.com

#3 Ryan

Ryan

    Great White

  • Industry
  • PipPipPipPip
  • 1053 posts
  • Gender:Male
  • Location:Fort Lauderdale, FL

Posted 02 July 2013 - 08:06 AM

That lens will definitely focus without the extension, and I'd venture to say that the results will be indistinguishable with and without.  So this isn't the issue, and I'd keep looking.


founder of Reef Photo & Video
manufacturer of Zen Domes

distributor of Nauticam in the Americas

 

n2theblue at reefphoto.com