Jump to content


Member Since 25 Oct 2007
Offline Last Active Sep 16 2015 06:09 AM

Topics I've Started

Shawn Heinrichs whale shark photos

19 May 2015 - 01:19 PM

I just caught a guy on facebook  ( Alan Alexandre) selling whale shark tours out of Cancun and blatently stealing Shawn Heinrichs photos. I asked the guy if the photos were his. Yes....and then after confronting him further,  they were taking by a japanese guy? hahahahahaha Shawn doesn't look Japanese to me. he's definately taller! :bye: This is one of the photos that caught my attention right away....        http://www.bluespher...htbox[2686]/0/.             That photo was taken when Richard Branson was down here. The guy blocked me now on facebook..... 

WTB Lens gear for Sony FX1 with Gates Housing

27 April 2015 - 08:21 AM

Anyone got one to part with? Sony FX1/Z1 lens gear from a Gates Housing. Thanks

WTB. Grips for Amphibico Phenom FX1/Z1 Housing

09 April 2015 - 09:50 AM

Long shot at this but maybe someone has. Im looking for the electronic grips for an Amphibico Phenom FX1/Z1 housing. I just missed out on buying a complete housing on ebay for $300! PM me if you have something that may work for me. thanks.

Acrylic Dome Port Scratches Repair

20 October 2014 - 12:50 PM

I had some bad scratches on my acrylic dome port that have appeared in my images. With limited resources here in Cozumel, I went to a paint store and found some 1500 grit wet sandpaper. I went to an auto supply store and bought some Turtle Wax Polishing Compound. First I sanded out the scratches with the wet sandpaper ( 1500 grit). I did this lightly and took my time. I then used the Turtle Wax Polishing Compund to remove the scratches from the sandpaper. Lastly, I used toothpaste as a final polish. Thing looks like new now! I was looking at buying one of the expensive kits others have recommended but this does an excellent job and Im out maybe $5? :uwphotog:

Canon 7D "cannot communicate with battery" error Repair

20 October 2014 - 05:28 AM

Ive had an issue with my canon 7D for over a year now. The camera would not read the battery and the error message "cannot communicate with battery" was the first thing one would see when you turned it on. Also, a fully charged battery would be dead in about 2 days even when the 7D was powered off. I had a problem last week where the camera would not turn off and the shutter would not release. Removing the battery was the only way to reset I guess? I looked all over the internet to see if anyone has had the same issues......there were lots. Many people suggested different fixes. I read someone had sent their camera back to Canon for repair and that there was a problem with a loose screw on a pc board inside. Being the person I am, I took it upon myself to open the 7D up and take a look. Low and behold, there was a screw that had come off one of the pc boards and was loosely inside the camera. Obviously causing some short to drain the battery, give error message. I put the screw back into its hole on the pc board and reassembled the camera. Works perfect now, no battery issues, no error message. This is something that Canon must be aware of as there is a lot of people on photo forums with the same problem. Its an easy fix but definately not worth the $200 - $500 some people are being charged. Here is a video I made of the simple procedure. :dancing: