Jump to content


cninsd

Member Since 14 Nov 2007
Offline Last Active Aug 04 2014 07:53 AM
-----

Topics I've Started

FS Nauticam NA-EM5 for OMD EM5, Flat port 56, Ultralight clamps and tray + more

03 August 2014 - 05:10 PM

I haven't been diving in many months so I'm finally giving up my UW camera gear to recoup some costs.  I've listed these on eBay as I don't have a sales/buyer reputation on the forum, and wasn't sure if people would be comfortable buying from me here.  Item links:

 

Nauticam NA-EM5 underwater housing for Olympus OM-D EM-5 (includes ball joint and hand strap):

http://www.ebay.com/...984.m1555.l2649

 

Nauticam Flat Port 56 for Olympus 14-42mm & 9-18mm lens + zoom gear + Red Filter

http://www.ebay.com/...984.m1555.l2649

 

Ultralight TR-DM tray + Ultralight AC-H Handle with Ball

http://www.ebay.com/...984.m1555.l2649

 

Three Ultralight AC-CSF New Style Clamps

http://www.ebay.com/...984.m1555.l2649

 

Sea & Sea YS-110 Strobe

http://www.ebay.com/...984.m1555.l2649

 

StiX 9" Strobe Arm With 3.5 Jumbo Floats (SX-309)

http://www.ebay.com/...984.m1555.l2649

 


OMD EM5 issues, how is Olympus repair?

18 July 2014 - 06:55 PM

I've had an Olympus OM-D EM-5 for a couple of years, but lately it has been acting up in two different ways:
 
1. Frequently the very first picture taken after startup is very under exposed, or completely black.  It is like the shutter isn't timed correctly.  Subsequent shots are mostly OK.
2. The shutter button is getting very flaky.  Frequently it doesn't register half or full pushes, and I have to wiggle my finger to get it to take a photo.
 
Does anyone have any experience sending their Olympus OMD in for service with similar issues?  It looks like the minimum I will spend is about $200 for service, so I want to make sure the results are good before I invest a lot of cash in an older camera (and I'll probably end up selling it soon anyway..).  Thoughts?
 
Thanks!
Chris