Jump to content


cwise

Member Since 26 Feb 2008
Offline Last Active Jul 10 2014 04:01 PM
-----

Topics I've Started

Strobe problems. Please help!

04 July 2014 - 05:22 AM

Hi everyone,

 

I have a Nikon D200 in a Sea & Sea housing with two YS90 DX strobes. The strobes are attached by a double sync cord which attaches to the camera hot shoe inside the housing.

 

I have my Camera flash settings on manual. With the pop up flash down. Strobes are set to on and the slave is off.

 

My strobes are firing intermitently. The sync cord is new and the wiring looks good.

 

Should I use a different camera setting? There are so many. Should I raise the pop up flash? Or lower the power of the flash?

 

I'm on an island with no other photographers to ask.

 

Please help. I'm at my wits end!

 

 

 

 


Nikon D200 strobe sync settings

03 July 2014 - 09:34 AM

Hi there,

 

Does anyone know what settings I should set on the camera to fire my external strobes? Manual not TTL.


Flash Sync Problem

03 July 2014 - 07:58 AM

Hi there,

 

I have a Nikon D200 with Sea & Sea YS90 DX strobes.

 

I'm having problems with my strobes  firing. Does anyone know what setting I should use on my camera?


WANTED Video Camera & Housing $2000 max

12 June 2014 - 08:10 AM

WANTED Video Camera & Housing $2000 max


Housing and tripod issue

05 August 2013 - 07:55 AM

Hi there,

 

I would like to use my Sea & Sea D200 housing with a Tripod but it doesn't have a screw hole. 

 

Does anyone have any ideas?

 

Thank you in advance   :starfish: