Jump to content


cwise

Member Since 26 Feb 2008
Offline Last Active Feb 06 2015 10:07 AM
-----

Topics I've Started

Seized Sync cord connection

06 February 2015 - 08:52 AM

Hi there,

 

I have a Sea & Sea sync cord and the locking nut has seized. 

 

Does anyone know how i can free it? I've tried vinegar and putting it in a vice.

 

Thanks


Mold in Nikon 105 vr please help

31 January 2015 - 12:58 PM

Hi there,

 

I'm on a tiny island in the middle of nowhere and I won't be going anywhere for months.

 

I have mold in my Nikon 105 vr.

 

Can anyone give me a dismantle guide so I can clean it myself?

 

Thanks in advance.


Strobe problems. Please help!

04 July 2014 - 05:22 AM

Hi everyone,

 

I have a Nikon D200 in a Sea & Sea housing with two YS90 DX strobes. The strobes are attached by a double sync cord which attaches to the camera hot shoe inside the housing.

 

I have my Camera flash settings on manual. With the pop up flash down. Strobes are set to on and the slave is off.

 

My strobes are firing intermitently. The sync cord is new and the wiring looks good.

 

Should I use a different camera setting? There are so many. Should I raise the pop up flash? Or lower the power of the flash?

 

I'm on an island with no other photographers to ask.

 

Please help. I'm at my wits end!

 

 

 

 


Nikon D200 strobe sync settings

03 July 2014 - 09:34 AM

Hi there,

 

Does anyone know what settings I should set on the camera to fire my external strobes? Manual not TTL.


Flash Sync Problem

03 July 2014 - 07:58 AM

Hi there,

 

I have a Nikon D200 with Sea & Sea YS90 DX strobes.

 

I'm having problems with my strobes  firing. Does anyone know what setting I should use on my camera?