Jump to content


divebutt

Member Since 28 Jul 2008
Offline Last Active Apr 19 2009 03:37 PM
-----

Topics I've Started

DS51 and the G9.....

19 April 2009 - 06:56 AM

So....

Picked up a DS51 for my G9 in an Ikelite housing and am trying to make it work.

I set the strobe on TTL and sometimes that little red arrow shows up on the screen and the strobe is controlled by the camera. Sometimes, it just triggers full power.

Any advice?

Ikelite Servicing

19 March 2009 - 05:53 AM

Hi all,

Looking at getting my Ikelite G9 housing serviced. They're saying $125 plus return shipping. Is this the way to go or is there a better option?

WTB Ikelite Strobe

12 March 2009 - 10:56 AM

Hi all,

Looking for a DS-51 or better with current TTL upgrade. Arm and TTL cord are a bonus...

PM me if you're looking to get rid of something. Don't worry about shipping to Canada, would ship to US address from US seller.

Thanks!

Matt

New Ikelite housing - Scratch!!

06 November 2008 - 09:47 AM

Hi guys,

Picked up a new Ikelite housing for my G9.

When I first removed the back I noticed a light scratch on the housing portion right where the oring seals. It's enough to lighty catch a finger nail and passes compeltely through the o rings seal. I'm thinking that this would make a great leak....

Planning on calling Ikelite and seeing what they can do. I would imagine it could just be buffed out pretty easily.

Any advice or experiences?

Thanks!

New Ikelite Housing

21 October 2008 - 03:31 AM

Well, I made the leap and dropped the cash and my new G( IKelite housing is on its way to replace my Canon housing.

That being said, apart from reading and following the owners manual, is there anything special I should do when I recieve it? Any tips or tricks? I've heard a dab of glue on the cushions that turn the knobs doesn't hurt.

Thanks!