Jump to content


Member Since 24 May 2009
Offline Last Active Nov 22 2015 10:14 AM

Posts I've Made

In Topic: For Sale: 2 Keldan Luna 4X

12 November 2015 - 12:07 PM

Everything sold

In Topic: For sale Panasonic GH4 in Nauticam GH3 housing + Extras

01 November 2015 - 02:32 AM

Everything sold...

In Topic: For Sale: 2 Keldan Luna 4X

31 October 2015 - 07:26 AM

Some remarks:

- German Chargers

- Additional rear cap and o-rings


Shipping free within EU. Addtional costs for Shipping and Customs in other Countries.

In Topic: Flash to dark, howto correct?

16 October 2015 - 12:30 PM

Coming back from the Red Sea I have had there the phenomenon too, that I need plus 1.5 correction at the YS-D2 strobes using TTL. When using manual flash mode 1/4 or /18 flash power was enough....

In Topic: Flash to dark, howto correct?

03 October 2015 - 11:18 AM

Thanks guys!

@Jack: as usually you help me a lot!

My settings were first program mode, but then I changed to A, with f8. I wondered, that the Nikon always choose 1/60....ISO automatic is off, 100 chosen.


Nikon is set to TTL, S&S too, in the picture above no increase, better results with +1.5


I used matrix metering. standard setting WB


I will leave tomorrow for the Red Sea and will try the following:

Mode Manual, ISO 200-400 / Auto off, f8, 1/125, spot, white balance auto, flash + 0.3



@Jack: Zen 170 port arrived just in time! Thanks! My friend has a 8.5 Nautical port which I will check, too!

I will report you!


Thanks a lot! Sascha