Jump to content


jamsys

Member Since 06 Jun 2004
Offline Last Active Apr 29 2010 09:07 PM
-----

Topics I've Started

WTB - Focus Light

13 February 2010 - 01:23 AM

Purchased the small FishEye LED and need something bigger..

Anyone???

Ikelite Super Wide 6" Dome for Fisheye & Sync Cords FS

15 January 2010 - 02:46 PM

SUPER-WIDE 6 DOME PORT
For lenses with a 110 to 170 degrees angle of coverage. This port does not allow use of a port shade.

#5503.15 Lens less than 2.5 (6.30cm) 9/10

---------------------------------------

Sync cord

For Nikonos Strobes SB 103/104/105
with Ikelite dSLR Housings


#4116.31 Single (NEW

AND

#4116.32 Dual (Used)

Contact me with offers and questions

Thx!

Scott

Ikelike Fuji S2 Pro Housing for sale

03 January 2010 - 06:12 PM

I am selling my Ikelite Fuji S2 Pro housing as I switched to Subal

The hotshoe and bulkhead connector needs replacing (approx $150 per Ikelite) and prob a annual service

Fuji S2 Pro's are still available from KEH for about $200.00

Or pick it up for parts for your other Ikelite housing!

Make me a offer

Scott

Ikelite Ports and Sync Cords for Sale

02 January 2010 - 01:11 PM

I have the following Ports and Cables for sale

Dome Ports

#5503 ........ 3.1 (7.85cm) 7/10

#5503.50 ... 4.1 (10.4cm) 9/10

SUPER-WIDE 6 DOME PORT
For lenses with a 110 to 170 degrees angle of coverage. This port does not allow use of a port shade.

#5503.15 Lens less than 2.5 (6.30cm) 9/10

---------------------------------------

Sync cord

For Nikonos Strobes SB 103/104/105
with Ikelite dSLR Housings


#4116.31 Single (NEW

AND

#4116.32 Dual (Used)

Contact me with offers and questions

Thx!

Scott

Subal w/ S2 Pro will not Sync Flash???

29 December 2009 - 05:33 PM

Picked up a used Subal for my S2 Pro from someone I know takes good care of the product.

I have 2 bodies and 2 SB105's. I can not get the sync light to come on the S2. I only have one sync cord to try, but I did try both ports. The same setup used to workin my Ikelite..... The connectors for the strobe in the housing is set to TTL...

Thoughts???