Jump to content


Member Since 12 Jul 2010
Offline Last Active Yesterday, 04:26 AM

Posts I've Made

In Topic: Annoying Final Cut Pro Stutter

22 August 2015 - 08:38 AM

My wife had a similar problem when she went 4K, she had the latest and greatest MacBook Pro 6 years ago, she upgraded her mac pro with the 2015 latest and greatest and no longer has the stutter problem. Hope to dive with you guys again soon.

In Topic: Showreel

08 July 2015 - 10:10 AM

Wow, Loved it....

In Topic: The Choice: Build Upon What I Have Or Start Afresh...?

07 July 2015 - 05:28 AM

Being newish as you say, whatever system you end up using it helps tremendously to have a system that is as close to neutrally buoyant as possible. There are several options out there of various kinds of floats just for this. Last thing the reef needs is and over weighted diver with an over weighted camera.

In Topic: Need some help on an Aquatica D7200 problem

03 July 2015 - 07:20 PM

Backscatter is pretty fast at getting out parts, they have an East Coast store and West Coast store.

In Topic: Question on strobe power and Syncing with Camera D7100 YS 250 Strobes

05 June 2015 - 04:58 AM

There must be a setting not set quite right. One simple test, put the camera in the housing, hook up the sync cable and with the strobe pointed at the lens of your camera you should be able to tell. Set correctly you should get a completely blown out image, if not there is a sync issue. Either some setting on the strobe not quite right or in the camera. I have not had the 250's but but have had the 110's and now the D1's have had these problems and it's usually a setting on the strobe got switched inadvertently.