Jump to content


Seabeast

Member Since 22 Feb 2011
Offline Last Active Sep 19 2011 12:28 PM
-----

Posts I've Made

In Topic: Problem with buttons

14 July 2011 - 07:29 AM

Hi everybody! Here is some continuation of the store. I got the new set of buttons from Hugyfot for free (btw they sent it twice, because at first time the parcel was stolen on the post) and then replaced them, fortunately it's not difficult. Now I returned from the 3 week liveaboard on the Red Sea (thats about 40 dives) and it looks like everything is ok. I used the same gear (only difference is the al cylinder instead of s/s) and so hope the first time was just the random problem with the quality.

In Topic: Problem with buttons

26 April 2011 - 12:22 PM

My problem was, that i forgot to put the anode between the arm and the housing.

How do they look? There is no picture on the Hydronalin site. Is it the zinc rings as on the photo which I posted here before?

In Topic: Nauticam and Zen, dramas with internal flash

26 April 2011 - 02:09 AM

This is what I used with my 40D/50D in my fibre optic converted Subal

You steal my ring man =)

Posted Image

In Topic: Nauticam and Zen, dramas with internal flash

26 April 2011 - 01:42 AM

I have the same with Tokina + Hugyfot Dome. Just made a foam rubber ring, which I put on the lens and reflections are gone.

In Topic: Problem with buttons

25 April 2011 - 10:45 PM

It seems that housing already has zinc anodes. There are two washers on the bottom. I'm not sure about the metal, but it looks similar to zinc.

Posted Image