Jump to content


Alex Brown

Member Since 11 Oct 2011
Offline Last Active Mar 30 2013 03:02 AM
-----

Topics I've Started

Using the Canon 100mm f2.8L with Ikelite dome port rather than flat

30 March 2013 - 02:49 AM

Hello everyone.

 

Has anyone else shot with the Canon 100mm 2.8 L lens with the Ikelite 8" dome port rather than the recommended flat port? I have been using for a couple of months now while shooting in the Maldives and think I am starting to hit some limitations. I am shooting on a 7d and mostly use an adapted Marvels Cine Style picture profile with increased sharpness.

 

I feel the picture is resulting in softer edges and not behind able to focus as close with the dome port. Could anyone using the flat port give me some feedback on their focusing distances and how sharp they are finding this lens underwater?

I have a few pictures and vide on the following links:

 

www.flickr.com/pictures/basementvision

www.vimeo.com/basementvision

 

Cheers, Alex.

 

857762_477271862337015_850043410_o.jpg


Forgot to affix strobe cap to Ikelite housing for a dive...

30 March 2013 - 02:34 AM

Hello,

 

I was wondering if anyone might be able to advise me on my little hiccup today... I forgot to put the strobe cap on the housing, for where the cord screws onto the housing body of my Ikelite 7D setup. I only noticed I had not put the cap on at 20m :(

 

Are there any methods for ensuring the port is completely clean and salt free? I would be so upset if the strobe port contacts corroded from my error.

Thanks, Alex.

 

The port I am talking about looks like the one of the left (on the housing).

 

bh-ike-ike.gif