Jump to content


joez2391

Member Since 16 Sep 2013
Offline Last Active Today, 07:17 AM
-----

Posts I've Made

In Topic: ALERT: New photo restrictions at Crystal River Three Sisters

Today, 07:22 AM

I think that closing off the sides of the springs will do exactly what you said, create a more concentrated area of tourists.  I was at 3 Sisters yesterday and there were two large tour groups of snorkelers surrounding and crowding the manatees.  Plus a tour group of kayakers (6 or 7 of them) were also surrounding the manatees in the center of the spring.  had to wait until the tour groups got rounded up before I could take photos again.  Does anyone know how roped off the outer parts of the spring will be?  Those offer some of the best manatee photos.


In Topic: ALERT: New photo restrictions at Crystal River Three Sisters

17 December 2014 - 09:01 AM

I have submitted my comments, I think that eliminating the use of strobes is taking it a little far.  I've never seen the manatees be bothered by strobes anytime that I have worked with them.  Glad I'm going this weekend before the new laws take effect


In Topic: D7000 Ikelite, buttons on camera not working while at depth

17 December 2014 - 06:25 AM

just curious, if the lcd protector and eyepiece were left on, could that cause the lens to misalign with the nodal point and cause not as sharp photos? I will remove both before I use it from now on I didn't know you had to


In Topic: D7000 Ikelite, buttons on camera not working while at depth

16 December 2014 - 06:37 AM

thanks for the reply guys, I did have the eyepiece in still so maybe that had something to do with it.  I am going to crystal river this weekend to try it out, at least I know now that if the buttons aren't working something is jammed!  thanks for the help


In Topic: D7000 Ikelite, buttons on camera not working while at depth

08 December 2014 - 08:31 PM

that's what I was thinking too Bill, i'll have to double check the alignment next time I put the camera together.  The zoom ring was working fine so I don't think it was an alignment issue, it must've been a pushed button.  Was there a certain button that gets pushed so I can look out for it next time? 

 

By the way, I never thought it had to do with the vacuum, just wanted to mention it to rule out a leak. I have that and the 5inch precision port you made and love them both so far!