Jump to content


SParkinson

Member Since 06 Oct 2002
Offline Last Active Jan 09 2014 09:45 AM
-----

Topics I've Started

Pair of Ike DS-125s, Cords, chargers and charger adapter plugs

23 January 2013 - 08:18 AM

Hi all

Selling my Ike DS-125s. they're a few years old and will easily last a days diving (incl. a night dive using the "spotting" lights). Batteries are NiMH.

2 Rapid chargers with all the plug adapters that shipped from Ikelite originally

Never had an issue with water. have spare battery o-rings. These are completely reliable strobes that have never let me down.... well, only let me down when left turned on and the dozy owner didn't check them! Posted Image

One dual (used) sync cord in good working order

One single (brand new) sync cord in good working order

One Dual (used and has a dodgy connector) sync cord. This (i'm 95% sure) has a problem against the bulkhead connector where the cable gets bent. if you play with it it'll fire but best to chop and re-solder connector imo

all sync cords are the blue ringed digital cords.

I'm based in the UK and if possible, would (ideally) like to sell as a pair. I'd be happy to receive £850 ono for the lot but am happy to negotiate Posted Image If you would like ONE strobe, let me know and I'll keep a note of your name so if/when another member shows an interest they can both be sold separately.

Happy to send as many pics as you need...

Based in SW London.

Cheers

Hugyfot 7d Housing / Gears with a Tokina 10-17

19 November 2012 - 07:34 AM

hi all,

just got hold of the above and have a problem with the gears mating with the zoom control on the housing. I am currently waiting for an answer from the retailer i purchased this from but thought id ask here in the meantime?

the gear i was supposedly sent were GEA-6.511 and SIL-6.500 which are the correct parts i needed.... there was no part numbers however on the packaging so am wondering if what i was sent is not correct.

with the gear on the lens, mounted centrally on the zoom ring, then the gear does not engage with the gear in the housing..... if i move the gear on the lens further back (so that it cannot go any further as the manual/auto focus switch is in the way) then it JUST engages the gear.... and i mean JUST.... 1-2mm if that.

the gear i was send fits the diameter of the lens and it 16mm in depth... can someone who possibly has the same setup have a measure and see if theirs is the same?

..... or failing that, ideas appreciated :)

cheers
steve