Jump to content


shark6047

Member Since 21 Feb 2007
Offline Last Active Jul 19 2009 07:07 PM
-----

Topics I've Started

DS125 Beeping

26 July 2008 - 12:16 AM

I have two DS125 strobes and four Nimh battery packs all purchased within the last month.

When the battery packs are connected to the strobes, I hear a beep sound. This beep occurs every ten seconds. The strobes are not even connected to my ikelite housing and this beeping sound occurs. This is not the normal beep/wind-up sound associated with first turning on the strobes. I understand the capacitor wind up sound normally associated with strobes.

I swapped out battery packs, the same thing occurs with each strobe no matter which battery is attached. Regardless of setting (TTL, Full, 1/4, etc.), the beep happens. The only time it doesn't beep is when it is in the test setting. This beep occurs whether the strobes are attached to the camera/sync cord or not. They are not attached now and they continue to beep as I sit here. Leads me to believe it is a strobe only problem.

Any help/suggestions would be appreciated.

BTW, I've just e-mail ikelite as well.
Figures this happens on a Friday afternoon :blink:

If you have experienced this, please let me know what you're corrective action was.

Thanks in advance

ed

For Sale S&S Dx8000g kit w/2 YS-110 strobes

05 July 2008 - 10:20 PM

I just purchased a housing for my DSLR so I'm selling my Sea and Sea Dx8000g setup.

The Kit includes:
DX8000g Housing
8.1 Megapixel Camera
2- Fiber optic Sync Cords
2- Sea and Sea YS-110 strobes
Sea and Sea Arm light and Tray Double set
Extra O-ring

There is absolutely nothing wrong with this setup.

I'm asking $1,400.00 for the entire kit + shipping

Sea & Sea Dx8000g Kit