Jump to content

britwitt

Member
  • Content Count

    8
  • Joined

  • Last visited

Community Reputation

1 Neutral

About britwitt

  • Rank
    Starfish

Additional Info

  • Show Country Flag:
    United States
  1. I’m shooting with a canon T6i in an ikelite housing, with two ikelite ds 161 strives. I prefer to use the manual settings, however, the TTL system (or the operator) can’t seem to get it together. Over exposure happens more times than not. My understanding is that I set the aperture, set the shutter speed, set the ISO, then TTL will work out light. I’m just not getting it! Any suggestions would be most welcome. Thank you.
  2. Ikelite MOD PORT SUPERWIDE NEW STYLE. Complete with all parts and two extra O rings. Buyer will pay actual cost for shipping. Thanks, let me know if you have any questions. Pictures can be supplied if you give an email.
  3. Just checking on what’s ‘new’. Seeing if anything has more to offer. As it appears not, by my search’s, 8 will stick with my T6I. Thank you for your comments
  4. Hello, well here's the question. I have a Canon T6I. I'm considering an upgrade in the Canon family, as I can still use all my lens. I have looked at a lot of cameras and now have no idea if I should upgrade, and if I do... to what! Anyone changed from a T6i? what did you go with? Thanks for any ideas.
  5. I purchased a tamron 60 mm lens for my canont6i, all housed in a ikelite housing. I use dual ikelite stobes. However, I have been unable to get the stobes to fire while using this lens. No issues when using a canon 18-135 lens. Thank you for any suggestions to solve my problem.
  6. Interested, do you still have the complete package? Did you use TTL or slave for strobes? Thanks
  7. I am looking to make the move from digital still to hd video. Have you used the set up you are selling, and how did you like the results? How easy was the transfer of data from camera to computer for editing? Thanks, britwitt
×
×
  • Create New...