Jump to content

Kublah

Member
  • Content Count

    24
  • Joined

  • Last visited

Community Reputation

0 Neutral

About Kublah

  • Rank
    Clownfish

Additional Info

  • Show Country Flag:
    --
  1. Just a quick update. I ended up ordering some carabiners and they worked perfectly. I attached my strap to the crabiners and then unscrewed the bolt at the bottom of each handle and slid the carabiner up, then screwed the bolt back on. There is no way for the carabiner to open up, and everything is securely attached. I'll try to take some pics later and post.
  2. I also noticed that it all the sudden came back in on B&H, so I ordered it. received it yesterday and it is on my full setup now. Time for pool test #2, this time with camera and lens. Thanks all!
  3. Yes I was, and I see the problem now. I was laying the dome down and placing the ikelite housing on and twisting it into position vs laying the body down and putting the port on it. I think the reason I started doing that was because of the O-ring, which was on the port extender originally and it would just fall off if I turned the port upside down. I just realized that it doesn't cause any issues if I put the o-ring onto the housing though and flip how I was putting things together. Fixing that now solved all my other problems, because I was able to properly align the zoom clamp and sleeve then put the port on. Thanks, I know it was a noob question, but there are a lot of pieces to these things when you first buy them, and the directions are not always exactly intuitive. =)
  4. I finally have my Tokina 10-17 lens in for my 40D and the housing is all setup, however, I am having a terrible time with the zoom clamp/gear sleeve setup and am hoping maybe you guys can give me some advice. It is frustrating me enough that I am considering just removing the entire zoom capability all together and just setup the zoom at 10 or 11mm and call it a day. Anyhow, the trouble is that the Tokina lens is extremely small as many owners may know, so I have to use the sleeve (rubber piece with bungies that fits around the zoom ring). The issue is that there is no way that I can see where you can set everything up on your lens and slide it into the housing. The clamp (clear plastic piece) has to be installed between your housing and dome port. This means that when I go to slide the camera into the housing, I am trying to line up the two lines on the sleeve on my lens with the two lines on the clamp perfectly to slide in the body into the housing. I have tried 10 times and every time I wind up with not a good alignment and it ends up pushing the sleeve up on my lens and as a result I don't have any zoom capability. Am I missing something here or is it really this complicated? Any help you guys can provide would be greatly appreciated.
  5. UPDATE: Pool test confirmed that my worries are not valid. I wrapped the inside of the housing with tissue paper and a small towel, then headed to the local pool. Everything is working as it should, even at low pressure situation just below the surface. I even wiggled the dome back and forth with the body facing different directions and not a single drop leaked in, so everything seems to be great. Next test will be with camera and lens (soon as I get the lens)
  6. Wow, it is apparently as bad and widespread as I feared. =) Thanks everyone for the great info. Fortunately I have until May to pick one up, so I will keep my eyes open and jump on one as soon as it becomes available. If not, then I will fall onto the eBay option, but I would rather not deal with a shipment from Hong Kong, in case I have problems.
  7. What is the deal with this lens? I have my housing ready to go and I can't find the lens anywhere. B&H, Adorama, Amazon... everyone is out of stock for the Canon one, and nobody has any dates of when it will be available. Anyone know what the deal is with the crazy short supply on this lens? I have a trip coming up in a couple months and my housing is all setup for this lens, but I can't find the darn lens!!
  8. I purchased one of these Op/Tech water proof straps for my housing based on someone's suggestion on the forums here. I can't figure out how to attach it to my housing. It is made to attach to a regular camera loops, so I am left to McGeyver something. How are you guys attaching the neck strap to the housing? I was thinking of just using a couple of light carabiners... attaching the strap to the biners and then hooking those around the base of my housing grips? Anyone have a better idea? TIA for your help. http://www.bhphotovideo.com/c/product/3963...rap_Black_.html
  9. Thanks for the great info all. I will be taking mine to the pool this week...first without camera, and then I will try it with. This definitely puts my mind at ease!
  10. Great info! Thanks all, it will stay on my strobe. =)
  11. Just got my DS-160 in, and I read about the diffuser on the thing. The 1 stop loss from the diffuser does not seem like a huge deal, but do you guys actually find it useful? Do most of you carry it with you in your pocket and throw it on underwater when you need it, or just leave it on for the dive?
  12. Balrog, do the Stix float arms work on the Ikelite circular strobe arms? The picture shows them being put on a ULCS arm, but are they pretty easy to just rig to fit the Ikelite rounded arms? Is the only other option to completely replace the 6" Ikelite arm with something like a ULCS arm that has better buoyancy? I think I will definitely need to do something, because I have the same problem others have mentioned. The DS-160 is quite heavy and the locking bolts on the strobe arm are tightened quite a bit and still I have problems with the strobe bending the arms. I think underwater at least with a little bit of buoyancy help it should be better. I'm just struggling on which route to go.
  13. This is my first housing (Ikelite 40D) and I got the superwide port and 8" dome. Everything is the newer 4 lock design with the low profile locks. I am just wondering if I installed everything correctly, because when I connect the dome/port to the body, you just press it and it snaps into the low profile locks on the body. However, when I put the locking L bracket on that keeps it from popping off on accident, I still have about 3" of rotation play. In other words, I can rotate the dome/port about 3" clockwise/counter clockwise. Granted the lock is doing it's job and will not let me rotate it to the point where you can take it off, but is this normal or did I mess something up with the installation? It just seems like if you can rotate the thing, then water can get into it? The o-ring is there and provides some friction when rotating, but I just want to make sure I am not going to have a leak when I get it underwater. Thanks for any info other Ikelite users can provide.
  14. Thanks for the info, very helpful. I just got the housing in today and after setting everything up, I connected the arm to the housing and I think the length is actually really pretty good, so I think I am going to go with it. With one light above the housing, it seems to have enough reach. I will try it out in the pool, but will also probably shoot with it on my first trip and see how it goes. So the strobe arm does not have any buoyancy compensation in it? Does the foam you suggest wrap around the arms to add buoyancy?
  15. Before I start, I just wanted to say that I have already read through the strobe arm forum above, and understand the standard lengths recommended. I am in the process of setting up my first full underwater setup for my Canon 40D. I just ordered the Ikelite housing, 8" port and along with it a DS-160 Ikelite strobe package. The strobe is the first thing that has come in, so I have not connected it up to the housing yet to see how long the arm length will be, but at a glance, I am thinking the standard arm length is too short. I believe Ikelite ships it with a small 5" part that connects to the housing and then a 6" arm to the strobe. I am planning on doing only wide angle work underwater on my upcoming trip in May to Honduras, and I only plan on having the one strobe, which is why I purchased a more powerful 160 strobe. I am still on the fence and thinking of just trying out the standard arm length that it comes with and seeing what I can make happen, but given my setup with one light and WA work, do you guys think it will just be impossible to make it work? If so, what should I consider for arms? Should I replace the entire thing and go with another company to get a more standard 5X8 setup? Unfortunately Ikelite does not sell an 8", so I would have to get a 9" arm if I went through them, which would put me at a 5X9 I am guessing. Any feedback is greatly appreciated.
×
×
  • Create New...