Jump to content

Tom Shepherd

Member
  • Content Count

    18
  • Joined

  • Last visited

Community Reputation

0 Neutral

About Tom Shepherd

  • Rank
    Damselfish
  1. You would have to send your housing back to us in order for the firmware to be updated.
  2. The charger you have will not work with your battery pack. If you send an email with your address to repair@ikelite.com we will send you the correct charger. We also need to know the dealer that sold it to you. We need to contact them to let them know they are selling the incorrect charger for NiMH battery packs.
  3. The flash tube is made out of blown glass. What you are looking at is a nipple that is left from the process of the glass being blown. It is not anything to worry about. It will not get bigger. The flash tube in all DS-125s has it.
  4. When you get your port from B&H send us the extension and we will exchange it at no charge.
  5. Damien, Your best bet is to send the strobe directly to us. I do not think Innovations does any strobe repair. Include with the strobe a short letter describing your problem.
  6. Yes, it is just as Karl said. There is no need for a reference number. Include a small note describing the problem.
  7. Wahoo, If you send your housing back to us we will fix problem with a reprogrammed micro controller in the I-TTL circuit in your housing. The other option is to set the meter in your camera to infinity.
  8. Jorge, My first thought was that the battery pack was not charged, but since you tested both strobes with the same pack that can't be the problem. When you return the strobe I suggest you send whatever battery packs you have also. We will load tests them and make sure they are in good working order. Put a note in with the strobe telling us that you need it back by a certain date. You should be receiving an e-mail from our repair department.
  9. Jorge, I am sorry you are unhappy with your experience. I can assure you both of your strobes worked fine when they left here. Unfortunatly, we have no control over things once they leave our hands. Can you tell me what the defective strobe is doing or not doing? As for the mix up with the price quote, your strobe was not updated, it was essentially replaced. Because of the strobes age and the updates that have been made to this design since your strobe was new it made more since to replace it. You may not have noticed the new serial number. The cost of replacing your strobe was not supposed to be charged to you, miscommunication on our part. I apologize, and will take full responsibility. If you return the troublesome strobe to us we will definately take care of it for you.
  10. Yes, the port shade for the 8" dome is being developed as we speak.
  11. I am not sure what happened but we replied to your e-mail on 4/28. The reply was re-sent this morning. You can send the strobe UPS ground or whatever method is convenient for you. If you are leaving for a trip and need it back by a certain date be sure to state that in your letter.
  12. The shade for the 8" dome port is already in the works. I don't have any more information right now, but I can say it is being developed.
  13. I am not Ike, but I can answer your questions. Send the strobe directly to us at the address in my signature. Include with the strobe a short letter explaining your problem. You may want to include an e-mail address so we can contact you if necessary. If you have other questions you can contact us at repair@ikelite.com. From the description you gave it sounds like you may have a defective or broken flash tube.
  14. It sounds as if you need to send the strobe with the green light to us for repair. The green light is a confidence light that lets you know your strobe has quenched in TTL mode, it should only stay on for 2-3 seconds after a quench. There may be a problem with the micro-controller in the strobe. "When I shake the dual synch cord, the one with the red light fires and fires..." If the strobe is auto firing when you shake the cord, then the cord needs to be returned to us also. It sounds like your housing is working correctly. There is no need to send it or the working strobe to us.
×
×
  • Create New...