Jump to content

alin

Member
  • Content Count

    3
  • Joined

  • Last visited

Everything posted by alin

  1. Davephdv: Do you use TTL with your the WC-E68 and Aquatica dome port? I seem to consistently get overexposed shots with TTL and the dome port, especially with macro shots. The instruction manual seems to suggest that TTL can't be used since the sensor is blocked by the domeport. But, it seems that the dome doesn't obviously block that sensor. What's been your experience.
  2. I highly agree that fow WA work the DS-125 would be much better. I lost my diffuser for the DS-50 which would, I think, increase the coverage a bit. I don't think the decrease in output would be all that critical as I had the EV @ -1.3-2.0 for all shots. Even with that and a F-stop of 8.0, I would overexpose some shots...please see the anemonae shot. If you have the money, I think the DS-125 is much more versatile.
  3. Hi. This is my first post. I'm a newcomer to UW photography, but I am currently using the CP 5000 with an Aquatica housing and the 19 mm WC-E68 WA lens with the Aquatica domeport. I also use a Ikelite DS-50 strobe. The edges appear very sharp unless you're zoomed way in. I have a trip report posted on Little Cayman at the Rodales site Rodales Scuba Diving Magazine entitled "The perfect dive vacation..." All the photos taken were with the WA lens except for the Queen Angel. This was my first trip with this setup. I previously was using a Ikelite housing a Oly 3040 with the wireless TTL...which I could never get working real well. Any suggestions would be helpful as I'm about as green as they come.
×
×
  • Create New...