Jump to content

mr.reznovich

Member
  • Content Count

    11
  • Joined

  • Last visited

Community Reputation

0 Neutral

About mr.reznovich

  • Rank
    Sea Nettle

Profile Information

  • Gender
    Male

Additional Info

  • Show Country Flag:
    Australia

Recent Profile Visitors

2573 profile views
  1. I have for sale: - Nikon D7200 body, next to new condition- Nauticam Flash trigger for Nikon (for fast fiber optic flash triggering)- Nauticam NA-D7100 with brand new vacuum system (06/19), normal wear, never been flooded, fully serviced (06/19)- Nauticam 4.33''Acrylic Wide-Angle Dome Port for Tokina AT-X 10-17mm F3.5-4.5 (purchased 2nd hand, has some external discolouration that doesn't affect the shots in any way) This has been my favourite piece of gear, it is absolutely amazing for close focus wide angle.- Tokina AT-X 10-17mm F3.5-4.5 Fish Eye lens- Nauticam Zoom Gear for Tokina 10-17mm Fisheye Lens I might consider selling a set of two Sea & Sea YS-D2J Strobes if anyone is interested to purchase them with the above package, message for price.Please go check out my Instagram page https://www.instagram.com/lorenzo_underwater/ as all the photos you see there where taken with this setup. It has been simply fantastic for me and I've always taken great care of it, doing regular maintenance and servicing. Selling as I am switching to a FX camera system.Asking price is 4000 USD + postage costs. Shipping from Cairns, Australia.Feel free to ask any questions - lorenzoballarin@icloud.com
  2. Hi Everyone, I am getting hired by a charity organisation for a trip overseas as underwater photographer. I don't have any previous experiences like this, just checking if anybody can steer me in the right direction to come up with a contract to avoid troubles of any kind. I won't be paid as it's for charity but want to get covered for travel expenses and such. Any help would be greatly appreciated !
  3. Hi everyone, I just got a new o-ring for my Nauticam acrylic 8.5 inch dome as the old one was cracked and led to some minor leaks (just few drops) inside the dome. Just to clarify I'm talking about the black o-ring that seals the acrylic dome to the Port, and not the grey o-ring that simply seals the port to the housing. I have never changed this type of o-ring before, can anybody help with some directions, tips or particular techniques I should use when changing it? Thanks in advance
  4. Hi I have a 8.5" nauticam dome for sale, have a look at my topic if you're interested. http://wetpixel.com/forums/index.php?showtopic=62697&hl=dome
  5. Hi, I have for sale a Nauticam 8.5"(220 mm) Acrylic Dome port (18802) with Extension ring 20 with lock (21120). This acrylic of the dome is in good as new condition, not even a single scratch on it. This is a great dome with only a handful of dives, it always performed great for every kind of wide angle shot including excellent over-under. The dome shade has a few scratches on the bottom part, as can be seen from the photos, but that is unavoidable and obviously doesn't affect the photos is any way. Dome comes with shade and Nauticam neoprene cover, rear port cap and Nauticam Extension ring 20 with lock. Located in Cairns, Australia but will ship world-wide at buyers expense, payment with Paypal. Price: 700 USD
  6. Hi Everyone, I am looking to buy a NAUTICAM 18804 4.33" Acrylic Dome Port for Tokina AT-X 10-17mm, new or second hand. I would also be available to swap this for a 8.5" Acrylic Dome port in mint condition. Cheers, Lorenzo
  7. Hi everyone, I'm looking to buy a Nikon D500 or D7200 body + housing,Nauticam or Aquatica. Ideally I would be after a Tokina 10-17 with dome port too. Thanks, Lorenzo
  8. Hi everyone, Kinda re-opening someone else's topic from a few months ago with a problem that wasn't solved.... I’m experiencing some issues with my new Sea&Sea YS-D2 strobe (had it for 2 weeks and done about 25 dives with it), it used to work just fine till yesterday…. It seems that the strobe and the camera are not sync anymore... when I take photos on DS-TTL or Manual they are either completely dark/black, if I switch to Manual with pre-flash they are the opposite: completely white/super overexposed. Please note the strobe fires. I am not on "Slave TTL" (dark blue light) but on DS-TTL (light blue light). I also reset my G7X II to factory default settings . Also tried using a different G7X II and have the same issue. When I try the camera alone it works just fine. I checked that my eneloop batteries were fully charged and I also tried to connect my housing and camera to a customers YS-D2 and it worked fine. Also tried to change fiber optic cable. There’s definitely something wrong with the strobe, it’s not the camera or the fiber optic cable. The strobe fires everytime I take a picture! It looks to me that the timing is not right for some reason…. Any help would be greatly appreciated, Cheers guys!
  9. Hi Lorenzo here from Australia, new to the forum. shooting with a -Canon G7XII
×
×
  • Create New...