Jump to content

Search the Community

Showing results for tags 'Nikon D330s'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Administration
    • Announcements
    • Feedback
  • The Galley
    • The Galley: General Chat
    • Beginner Forum
    • Photo / Video Showcase
    • Classifieds
  • Gear and Tips
    • Photography Gear and Technique
    • Video Gear and Technique
    • Lights, Strobes, and Lighting Technique
    • Shooting Technique, Workflow and Editing
  • Planet Earth
    • Trip Reports and Travel
    • Conservation and the Environment
    • Critter Identification
  • Other
    • Copyright Issues, Non-Payment, Fraud, Theft

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests


Full Name


E-mail Address


Contact Phone


Mailing Address


Camera Model & Brand


Camera Housing


Strobe/Lighting Model & Brand


Accessories


Industry Affiliation

Found 1 result

  1. I've just taken delivery of a new Nikon D300s and Ikelite housing to match. I tried it out last weekend and all went well apart from one thing: the LCD won't go on when it's below any significant depth (10-15m) either by manually pressing the button or automatically after taking a shot which makes checking the histogram a bit tricky. If I'm shallower there isn't a problem which makes we think that it's a misaligned button getting pressed by the water which is blocking the LCD on function. Does anyone have any idea which button would do this and how to fix it?
×
×
  • Create New...