Jump to content

Search the Community

Showing results for tags 'PT-EP13'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Administration
    • Announcements
    • Feedback
  • The Galley
    • The Galley: General Chat
    • Beginner Forum
    • Photo / Video Showcase
    • Classifieds
  • Gear and Tips
    • Photography Gear and Technique
    • Video Gear and Technique
    • Lights, Strobes, and Lighting Technique
    • Shooting Technique, Workflow and Editing
  • Planet Earth
    • Trip Reports and Travel
    • Conservation and the Environment
    • Critter Identification
  • Other
    • Copyright Issues, Non-Payment, Fraud, Theft

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests


Full Name


E-mail Address


Contact Phone


Mailing Address


Camera Model & Brand


Camera Housing


Strobe/Lighting Model & Brand


Accessories


Industry Affiliation

Found 3 results

  1. I'm looking to buy an Olympus PT-EP13 Underwater Housing. Please message me if you have one for sale. Thank you, Divingmama
  2. I have an Olympus PT-EP13 Underwater Housing for the Olympus OMD EM5 Mark II camera, and the housing has flooded 3 times. The first time I thought it was the Zen wide angle port, and put the stock port back on. Soaked the housing in water and dried the springs, buttons, etc. well. All good for 6 months, then another major housing flood. Soaked and dried again, this time taking off the tiny screws that hold the port glass and cleaning sand off the 2 glass O rings. All good for a couple dives, then small amounts of water intrusion while diving around 80 feet. Took the housing down without the camera after soaking and drying again- no water intrusion. Took it down again without the camera, and there was water intrusion when pushing the buttons. At this point, I don't trust the housing any longer. Olympus already doesn't make the housing any longer and no store carries it. Does anyone have any suggestions? I really don't want to buy another camera and housing set up, and am severely bummed. Thanks, Divingmama
  3. I just bought a OM D5 MKII and PT EP-13 uw housing and am having a strange problem with the setup. When I use the kit 14-42mm lens and the EP 02 zoom ring, it all works on the surface to about 30', then the zoom stops working. It's purely mechanical, I can feel the zoom knob gear popping between the teeth of the lens gear. Coming back up makes the problem go away. It looks like a housing problem. I'm going to contact Olympus, but I wanted to see if anyone else has had this problem. I tried 3 different zoom rings, all with the same result. I just started a week long dive trip, needless to say I'm annoyed.
×
×
  • Create New...