Jump to content

Search the Community

Showing results for tags 'YS Converter /N'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Administration
    • Announcements
    • Feedback
  • The Galley
    • The Galley: General Chat
    • Beginner Forum
    • Photo / Video Showcase
    • Classifieds
  • Gear and Tips
    • Photography Gear and Technique
    • Video Gear and Technique
    • Lights, Strobes, and Lighting Technique
    • Shooting Technique, Workflow and Editing
  • Planet Earth
    • Trip Reports and Travel
    • Conservation and the Environment
    • Critter Identification
  • Other
    • Copyright Issues, Non-Payment, Fraud, Theft

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests


Full Name


E-mail Address


Contact Phone


Mailing Address


Camera Model & Brand


Camera Housing


Strobe/Lighting Model & Brand


Accessories


Industry Affiliation

Found 2 results

  1. Sea & Sea YS Converter /N; Model 50117 Very gently used and meticulously maintained. Includes bracket for mounting to my Aquatica brand housing handle. All is in working order. Shipping costs depend on your preference for speed, insurance, the weight and size of what you want such as any of my additional items for sale that you buy at the same time from my other current listings, etc. and so are not included here, but I will pass them on at cost. Price is suggested; I can consider any reasonable offer. For sale to buyers in the continental United States only. $300
  2. Hi all, Recently I bought a Sea and Sea YS /N TTL converter. (By the way, thanks again, Reubencahn, for it.) Though it's used it is in excellent shape. I tried it with my 2 Sea and Sea YS 90 Auto Duo and Nikon D70 and worked flawlessly. Then I tried the same set with my Nikon D7100 and TTL doesn't work. At first I thought it was some circuit inside Nauticam bulkhead... So I tested D7100 in the same exact wiring set up that I use the D70: with the D70 housing opened, connected its hotshoe to D7100 - no TTL! I also have a Subtronic Nova that I use with both cameras and TTL works well, so I'm out of solutions. Does anybody has experience with D7100 and Sea & Sea TTL? Any help would be appreciated. Cheers Alex
×
×
  • Create New...