Jump to content

Search the Community

Showing results for tags 'YSD1'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Administration
    • Announcements
    • Feedback
  • The Galley
    • The Galley: General Chat
    • Beginner Forum
    • Photo / Video Showcase
    • Classifieds
  • Gear and Tips
    • Photography Gear and Technique
    • Video Gear and Technique
    • Lights, Strobes, and Lighting Technique
    • Shooting Technique, Workflow and Editing
  • Planet Earth
    • Trip Reports and Travel
    • Conservation and the Environment
    • Critter Identification
  • Other
    • Copyright Issues, Non-Payment, Fraud, Theft

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests


Full Name


E-mail Address


Contact Phone


Mailing Address


Camera Model & Brand


Camera Housing


Strobe/Lighting Model & Brand


Accessories


Industry Affiliation

Found 6 results

  1. Hi, Up for sale is a like-new Howshot fiber optic Snoot that fits the Sea & Sea YSD1 and YSD2 underwater strobes. The sale includes 3 Fiber Optic arms and three different lenses for each arm. One arm is for the focus light and the others are for subject illumination. I don't use it nearly as much as I thought I would so it's time to let it go. It can be yours for $190 which includes shipping to buyer. Paypal only. ​14 day return OK. Buyer pays return shipping I live in San Mateo california Thanks for looking, Larry
  2. Wondering if anyone else have the same issues with YS D2? I was at Raja Ampat recently using a New set of Sea & Sea YS D2 X 2. Both strobes fire with no problem when I tested it on the LOB. However, when I dove to about 15 to 20 meters, both strobes fire for about 10 to 15 times and then the right strobe stopped firing. It was giving me blinking signals, indicating that my battery is dead. I swtched On and Off. It doesnt work. Thinking I must have forgotten to charge one set of the batteries, I tried again during the 2nd dives. As for my 2nd dives set up, I decided to swap the strobes from left to right. Just to make sure it wasnt my syn cord that was giving me problems. I tested again on the LOB before diving with it and both sets of strobes fires well with no problem. I have 16 pieces of Enloope batteries so, i have the privilege of using a different set. Same thing happened again. it will fire for about 10 to 15 times at the depth of between 15 to 20 meters before the same strobe which was initially giving me problem failed to fire again!!! This time there was no warning lights. It just cut off. When I turn On and Off again, the blinking red/gree lights appeared warning i have problem with battery or something else wrong with it. I tried one more time with the YS D2, checked and re-checked everything syn cord etc. Swapped the unit from left to right. It fires well on LOB. Again, it will fire for 10 to 15 times, at about 15 to 20 meters in the water before the same unit dies on me. Same warning blinking lights. Fortunately, I have also brought along my old set of YS D1 x 2 just in case. I decided to revert back to YS D1 for the rest of my dives. I have no problem with the YS D1. It fires well on LOB and also in the water all with the same settings. On 12th Dec 2015, I have returned the problem unit to my retailer in Malaysia which was then sent to the distributor in overseas. I have no idea who the distributor is but I was told, it has been sent back to Sea&Sea in Japan. I have written an email to the retailer in Malaysia describing my experience with the problematic strobe which was then forwarded to the ditributor and Sea&Sea. I have indicated I do not want a Repair unit as it was brand new when I used them. As at today 5th Jan, 2016, I have no new information or updates despite following up. On the positive note, while i had the 10 to 15 times of usage, I must agree the beep sound to re confirm that my strobes were ready to fire again are very useful. The lighted up indicator and knobs are one of the plus point too. Its just the reliability that kills the overall experience of this new YS D2. Does anyone else have similar problem? I will update on the progress of YS D2 which has been returned to the retailer.
  3. Buy one or a couple of strobes in good condition Sea & Sea YS-D1 no more than $250 Sea & Sea YS-D2 no more than $350 or Spare part: Main circuit assembly for YS-D2.... also i need service manual for repair YS-D2 (my ys-d2 no correct working...) Payment PayPal, Shipping to US address
  4. Hello, I’m having trouble getting my two YS-D1 strobes to fire similarly. I’m currently at work so will have to post more examples later. My kit consists of an EM-5 in Olympus housing, flash set to fill, fiber optic cables, each connected directly to housing, no diffusers, eneloop pro batteries, two 5+8 arms and using between F3.5-F8, 1/60-1/250 shutter. What I’m noticing is that when: Setting both strobes to TTL, EV+0, equally spaced, level with lens L strobe: Correct exposure, but does not fill left of the frame R strobe: Very under exposed, completely fills right of the frame. Will post example later. Trying to compensate R strobe L strobe: TTL, EV+0 as above R strobe: Manual, EV+full, slightly under exposed compared to left of frame, fills r side of frame. Will post example later. After playing with the settings more, to compensate R strobe L strobe: TTL, EV-.5, R strobe: Preflash (but camera isn’t using a preflash!), EV+1 ,and the strobes are finally within a ballpark intensity of each other. But the left still isn’t filling as much of the frame as the right. See attached image. Any idea what's causing this? Or, anything I can do before sending them out?
  5. Used about half a dozen times and still in as new condition. Two Sea & Sea YSD1 strobes with Aquatica arms and fibre optic cables Also a few spare Aquatica brackets, attachment, booklets etc Located in South East Queensland Free postage within Australia $1750 AUD or $1250 USD
  6. I have three Sea&Sea YS-D1 strobes for sale. I purchased these strobes last year and have used them on two week long vacations. One of the strobes was my backup strobe and has never been in the water. The ones that have been used were protected by a neoprene cover. None of the strobes have any problems and were never flooded. All of the strobes come with everything just as new including the box and packing materials. See the attached pictures. Buyer pays shipping and PayPal fees from Cincinnati Ohio USA. New Strobe $575 Used Strobe $500
×
×
  • Create New...