Jump to content
Stijn

Ikelite DS 125 Malfunction

Recommended Posts

Hi

 

I have an Ikelite DS 125 strobe. I have not used it for a year. THis morning I want to turn it on but get no reaction or lights so I decide to charge the battery. It is a standard charger which came with the strobe. it has a charge LED and a power LED. When I connect it the power LED starts flashing very quickly.

 

Is this because it's charging? or is there a malfunction? I have no Idea what I am doing wrong.

 

If there is someone with the same strobe or has experience with this pls let me know.

 

Thanks!!

Share this post


Link to post
Share on other sites

You should fully charge your batteries after every use, and for a few hours each month also. Leaving the batteries without charge for a year will shorten their life, and may allow cell reversal, requiring replacement.

 

The Smart Charger Indicator Lights have three modes:

 

Slow Blinking: deeply discharged, so the charger is slow charging your battery.

Continuous: quick charging.

Rapid Blinking: fully charged

 

I doubt your batteries are fully charged, so probably they are being slow charged to bring them up, then the charger will go to quick charge. Leave the charger connected overnight, and see if the strobe works properly with the charged battery. If not, you need a new battery set.

Share this post


Link to post
Share on other sites

Thanks for the advice. I plugged in the battery and got the very quick flashing but after a while it started with the normal charging so everything is back to normal.

Share this post


Link to post
Share on other sites

I did similar, got tired and forgot to charge, next day my 3-year old DS125 was clear dead. It charged up fine. The manual says not to drain completely and charge monthyly which I did, until now. Will this one incident shorten battery life? Thanks!

Share this post


Link to post
Share on other sites

Sponsors

Advertisements



×
×
  • Create New...