Jump to content

Recommended Posts

I just had to let everyone know how GREAT the service is at Ikelite. Sent a DS- 125 in about a week ago with a battery issue, they requested the strobe head also and I sent it to them. UPS just delivered the whole thinkg back, repaired, tested, and modified at NO CHARGE! About 1 weeks turn around time even with the second item being sent in. Why would anyone want to use any other equipment manufacture when you have someone like Ike and his crew? WOW, what service! This is my second time using Ikelite housing/strobes and i'm sure it won't be my last. Thanks Ike and whoever you have working for you. :D:lol::lol:

Share this post


Link to post
Share on other sites

Hi,

 

Glad to hear you had great service.

 

What was wrong with the battery?

 

Cheers

James

Share this post


Link to post
Share on other sites

Hi, James. I found that the foil on the circuit board in the battery had fried open, and they thought it might have something to do with the older style DS-125 having a short from the aiming light mount. Replaced the aiming light holder with a newer style, and repaired or replaced the battery. Now it all works just perfect. I wish more companies would handle service in a more customer oriented way. I had no problem paying for the repair, but they felt that it wasn't necessary.

Share this post


Link to post
Share on other sites

Hurray! I love companies like that. It makes me practically want to GIVE them money.

Share this post


Link to post
Share on other sites

On the other hand I just had 2 DS-125s returned from Ikelite after repair and upgrade and 1 of them doesn't work, unbeliveable service indeed. :lol:

No doubt they are fast, but are they good?

Also for the record, I got quoted, by their repair dep., a cost of $350 bucks for an upgrade when in reality it is stated $150 in their website for that particular strobe sn. Complained and the repair dep. corrected the cost, but what if I hadn't??...so, since I do not particularly like these mimicks I just ordered an Hartenberger 250 instead of the foreseen twin DS 200 and if I am happy with the product and service I will order more.

Like people say, it is hard to get new customers and even harder to keep them but it is very easy to lose them.

Hope Ikelite makes good on this one, we will see.

Share this post


Link to post
Share on other sites

Jorge,

 

I am sorry you are unhappy with your experience. I can assure you both of your strobes worked fine when they left here. Unfortunatly, we have no control over things once they leave our hands. Can you tell me what the defective strobe is doing or not doing?

 

As for the mix up with the price quote, your strobe was not updated, it was essentially replaced. Because of the strobes age and the updates that have been made to this design since your strobe was new it made more since to replace it. You may not have noticed the new serial number. The cost of replacing your strobe was not supposed to be charged to you, miscommunication on our part. I apologize, and will take full responsibility.

 

If you return the troublesome strobe to us we will definately take care of it for you.

Share this post


Link to post
Share on other sites

Jorge,

As you can see by Tom's reply they are indeed a great service organization. I have never had a problem with any repaired items once i've got them back, and usually it's my fault if they break in ther first place. As I said in my original post, they are a great manufacturer and I have no doubt that my next housing and strobe setup will also be Ikelite. Keep up the grat work Tom!!! :blink::o

Share this post


Link to post
Share on other sites

That ws meant to say Great work, Tom.

Share this post


Link to post
Share on other sites

Tom,

I am glad for your answer, this is the Ikelite I decided to buy my strobes from.

Both strobes were well packed from Ikelite and received last Friday 19, no exterior signs of impact on the box, 1 works perfectly 1 doesn't. <_<

The one that is not working does not seem to be charging [no charging sound] and does not fire [even shorting trigger to ground, maybe because there is no charge in the capacitors?], no ready lights come up, modeling light works but that is just a direct connection between battery and lamp. The strobe was tested with same battery and cable as the other, fully working, strobe.

I have sent Ikelite's repair dept an email and the strobe will be on its way to you by courier next monday 22. I still might need them for SA in mid-june, despite my new aquisition.

Hope that it gets fixed and shipped back quickly.

 

Best

Share this post


Link to post
Share on other sites

Jorge,

 

My first thought was that the battery pack was not charged, but since you tested both strobes with the same pack that can't be the problem. When you return the strobe I suggest you send whatever battery packs you have also. We will load tests them and make sure they are in good working order. Put a note in with the strobe telling us that you need it back by a certain date. You should be receiving an e-mail from our repair department.

Share this post


Link to post
Share on other sites

Glad to hear this....

 

My Ikelite SS-200 suddenly exploded at the fuel gauge (battery indicator) at 20m depth.

The strobe was purchased in 2004, always stored at its hard case (pelican), I was use it twice or 3x every year.

 

Now they (ikelite) still evaluate and inspect mine, hope and pray ikelite can help me out this problem with their best service.

 

Regards,

Share this post


Link to post
Share on other sites
Sign in to follow this  

Sponsors

Advertisements



×
×
  • Create New...