Jump to content
Lee450

Ikelite Housing Leak

Recommended Posts

After 30 or so dives with my Ikelite Housing I started have problems with the TTL and Strobe adjustments on the Housing. To make a long story short I sent the housing, strobe and cord back to Ikelite and they found the problem. They said the electronics inside the housing were corroded. I notice while diving that a drop of water came into the housing when I pushed the (+) button on the back to increase the flash exposure. When I saw that I quit pushing the button until i got to the surface and could check it. As it turned out I had about one or two drops of water in the housing when I surfaced. According to the Ikelite service department this is enough (one or two drops) to corrode the electronics inside the Housing.

Just so you Know Ikelite replaced an oring on the push-button and Repaired the Housing with no charge which I thought they should have done.

 

My question is has anyone else experienced this problem? It seems to me one or two drops inside the Housing should not be enough to damage anything. If it does then I can not imagine others not having the same problem.

 

Lee

Share this post


Link to post
Share on other sites

Hi Lee,

 

I'm sorry to hear that you had a minor leak, but pleased to hear that it is all sorted out now. I haven't heard of this specific problem occuring before, but there is always a first.

 

My question is has anyone else experienced this problem? It seems to me one or two drops inside the Housing should not be enough to damage anything. If it does then I can not imagine others not having the same problem.

Even one drop of seawater is highly corrosive and it doesn't surprise me in the least that this was the source of damage. I have seen instances where corrosion has occurred on sync cord contact just from salt spray which was less than the drops you mentioned. Salt water is very potentent stuff.

Share this post


Link to post
Share on other sites

Sponsors

Advertisements



×
×
  • Create New...