Jump to content
Sign in to follow this  
Alex_Mustard

Help with my website

Recommended Posts

I am having a strange problem with my wesbite, which is not working properly:

http://www.amustard.com/

 

The home page loads OK - but any link on the site just seems to reload the homepage.

For example - this link should load the about page:

http://www.amustard.com/?page=cvphoto&...hoto&size=s

 

The content is still there:

http://www.amustard.com/cvphoto.php

 

Possibly related to this issue is the fact that my Webhost migrated my site to a new server over the weekend? Or maybe it is because I took the picture of me and the Queen off the front page last week!

 

Anyway, I know there are many people here at Wetpixel with skills in this area. And any help would be most appreciated.

 

I have also posted a help message to the Webhost - so it may miraculously cure itself in the meantime...

 

Alex

Share this post


Link to post
Share on other sites

Hi Alex,

 

I dont know what CMS you use, but it looks to me like some of the database has become unlinked. You might have to go into the backend and redirect your CMS to look for the new database your data is now sat on.

 

Did they switch from linux to windows servers or vica-versa?

Share this post


Link to post
Share on other sites
...snip...

 

Possibly related to this issue is the fact that my Webhost migrated my site to a new server over the weekend? Or maybe it is because I took the picture of me and the Queen off the front page last week!

...snip...

alex, it definitely sounds like the migration of the web hosting did some damage to your cms application.

things that i needed to change after the same type of adventure happened to my site were:

- is the DB name/server name coded somewhere in your CMS (it probably is - you need to see if that server/db name has changed and potentially update you code

- clear the cache (on the cms, not your browser :))

- look for any hard coding you may have done in your linking that involves full path names that could be a reason for this as well

- look for any discrepancy in the folder names that you now have to use - this could cause some issues and the system would not find the links

 

that's about all i can think of...

hth

/paul

Share this post


Link to post
Share on other sites

Looking at it again it might be your predefined charset in your xml. Certain ones are missing certain characters (and have different codes to get symbols) and this can cause a conflict, which would explain the amperstand issue.

 

I think the most common charset is ISO8859-1, it might have switched over to UTF-8 encoded thus dropping your coded links.

 

Cor is your man for this, he's a php whizz!

Share this post


Link to post
Share on other sites

Strange problem - I would just email the host, but as an interim you may want to try:

 

a,) deleting all your cache files (probably have a root directory called "cache" or can be done from the CMS backend - could also turn caching off in the backend)

b,) renaming your htaccess file (if you have one it should be in the root) to render it inoperable and then checking the links again

 

if it is htaccess then either your cms supplier or host will be able to work out what line is causing the issue

Edited by whitehead

Share this post


Link to post
Share on other sites

Unfortunately my help email to my website host has not received any replies yet.

 

Thanks for the suggestions. I don't really understand that many of the answers! And I don't want to fiddle about with anything I don't understand.

 

Alex

Share this post


Link to post
Share on other sites
Looking at it again it might be your predefined charset in your xml. Certain ones are missing certain characters (and have different codes to get symbols) and this can cause a conflict, which would explain the amperstand issue.

 

I think the most common charset is ISO8859-1, it might have switched over to UTF-8 encoded thus dropping your coded links.

 

Cor is your man for this, he's a php whizz!

 

Simon - after much hunting I found that on my existing site:

 

<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1" />

 

Where would I look to see if this is changed on the new server?

 

Alex

Share this post


Link to post
Share on other sites
I don't really understand that many of the answers!

 

Alex

 

 

Heheh....

 

Neither did i!

Share this post


Link to post
Share on other sites

Hi Alex,

 

I don't think character encoding is going to be what is affecting your site, it looks more like a configuration problem to me. I think Paul was definitely on to something when he mentioned Database settings and Folder paths.

 

A quick question to help diagnose your problem: do you have a configuration file that contains loads of setting with horrible geeky names such as "ApplicationRootPath" in it? This could be a *.xml, *.config or other file you can open in a text editor (like notepad) in the base of your web application. If you can't find a file with loads of settings in it, let us know what product you're using for your website and one of use geeks can figure out where it should be (hopefully).

 

Not sure how the new fangled PHP websites work (I'm more of a Microsoft web technologies guy) but it definitely sounds like a setting didn't get carried over from one server to another over the weekend.

 

Btw, am on British time at the moment so feel free to PM me with any specific questions you don't want on the board.

Cheers,

 

Gerard

Share this post


Link to post
Share on other sites
Simon - after much hunting I found that on my existing site:

 

<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1" />

 

Where would I look to see if this is changed on the new server?

 

Alex

 

Hi Alex,

 

That charset should be fine, Mike and I are running a CMS / gallery software which has conflicting charsets causing error (not that Mike has a clue about any of this, he sees himslef as the creative director... A Yapese Buddha if you will) and i thought this might be the case, but 8859-1 is the 'standard' (or so i believe)

 

 

When i changed our site to a different server i had to redirect where my cms looked for the SQL database.

 

ie the original database was on mysql1.xxxx and the new one on mysql3.xxxxx - the webhost will have used phpadmin to backup and move your site, but will not have updated the paths in your CMS, so your site is till looking at mysql1.xxxxx

 

PHP / MySQL is a total pain to learn, just look at the books on amazon - they are usually 6" thick!

 

It's speculation without knowing what CMS etc you are using, and like Gerard feel free to pm me if you like.

 

You will also note that mine and MV's gallery is not working, so i am in no way claiming to be an expert!

 

The most important thing is DO NOT CHANGE ANYTHING until you are sure, because it is a pain to remake the whole site, sit tight, im sure an answer will come to light soon!!

Share this post


Link to post
Share on other sites

Thanks for the help. It is now working correctly again. The problem was:

 

"The new server does not have register_globals turned on in default php.ini.

 

I have turned register_globals on in public_html/php.ini file. Your site is

now working correctly. I apologize for the inconvenience."

 

Alex

Share this post


Link to post
Share on other sites
Sign in to follow this  

Sponsors

Advertisements



×
×
  • Create New...