Jump to content
RVRinTAS

Help Critical - New Ikelite D300 housing missing seals? Compare yours to mine please...

Recommended Posts

Hi all,

 

I just got my new D300 Ikelite Housing, and was having a good look at the inside of it... This may apply to ther Ikelite Housings, not just D300...?!

 

I then notice that the bolts the hold the top clip (used to latch the cover closed) - had some black seals under the bolt heads on the inside...

 

Then I noticed that the left and right clips had these missing... I can't seam to see any other seals for these bolts...

 

If you are reading this, can you please have a look at your housing and see if yours has these and please post a reply here to tell me what you see on yours... Do you have all the black seals under all the bolt heads...?

 

Some pics here to help out.... Link to Google Pictures

Edited by RVRinTAS

Share this post


Link to post
Share on other sites

Hi All - OK - I just got the torch out... Not sure why they don't all have the little black things...

 

BUT

 

The seals are a set of 2 o-rings on each bolt shaft within the wall of the housing...

 

Any one want to confirm my findings?

 

Thanks

Edited by RVRinTAS

Share this post


Link to post
Share on other sites

You might get a definitive answer if you contact Ikelite directly about your concern. At least that way, if there is a problem, you can tell them you spoke to them about the issue prior to using the housing.

 

You can also do a pressure test on it without the camera.

Share this post


Link to post
Share on other sites
You might get a definitive answer if you contact Ikelite directly about your concern. At least that way, if there is a problem, you can tell them you spoke to them about the issue prior to using the housing.

 

You can also do a pressure test on it without the camera.

 

Sounds like good advise.

 

I have to ask the obvious " What was wrong with asking the store you got you housing from" ?

Share this post


Link to post
Share on other sites

Hi - It is 12:10am here, and all shops are closed (including the store I bought the Ike gear from) - I will call off dive for Tuesday and look in to it...

 

I was using the forum to see if Ikelite housings were the same...

 

Cheers

Share this post


Link to post
Share on other sites
Hi - It is 12:10am here, and all shops are closed (including the store I bought the Ike gear from) - I will call off dive for Tuesday and look in to it...

 

I was using the forum to see if Ikelite housings were the same...

 

Cheers

 

Ikelite has superb customer service - definitely worth a call and or e-mail directly to them (ikelite@ikelite.com)(317-923-4523). Skip the middle man.

Good luck.

Andy

Share this post


Link to post
Share on other sites
Ikelite has superb customer service - definitely worth a call and or e-mail directly to them (ikelite@ikelite.com)(317-923-4523). Skip the middle man.

Good luck.

Andy

 

Great - Email Sent - I will post reply...

 

Cheers

Share this post


Link to post
Share on other sites

You should dive a new housing without camera & move all the controls just to make sure everything is OK.

Share this post


Link to post
Share on other sites

Hi,

I took a look at my D200 housing and my D70 housing and they both are set up just like yours.

I have dove both housing without any problems.

Hope this helps

 

Stephen

Hi All - OK - I just got the torch out... Not sure why they don't all have the little black things...

 

BUT

 

The seals are a set of 2 o-rings on each bolt shaft within the wall of the housing...

 

Any one want to confirm my findings?

 

Thanks

Share this post


Link to post
Share on other sites

My brand new Ikelite D80 case looks the same but it was not in water yet

Michal

Share this post


Link to post
Share on other sites

;) - I Love this forum - Thanks everyone. That is great news....

 

I wonder why they did it - ?

 

Anyhow - Thanks again.

Share this post


Link to post
Share on other sites

Response from Ikelite - All Good...

 

 

Subject: Re: FW: D300 Housing Question...

 

Thank you for the inquiry. The black seal that the customer identifies under the top latch is actually a black spacer washer rather than a seal. This black spacer washer is not needed for the two side latches. I apologize for the confusion.

 

Regards, Duane / Ikelite

Share this post


Link to post
Share on other sites

Sponsors

Advertisements



×
×
  • Create New...