Jump to content
Sign in to follow this  
Grayscale

Broken strobe head

Recommended Posts

Hi.

 

I removed the batteries to my strobes earlier today for charging.

I sadly found some major cracks on the strobe head where the head and battery locks together.

 

I don't think it's my fault since I'm careful with my stuff (sure they have some bruises but some things you just can't avoid).

Have anyone else had problems like this?

 

-Built june 2007 (according to the battery at least)

-140 dives or so

-Never saw it coming like a growing crack. Suddenly it was just there.

 

I've contacted Ikelite and I'm waiting for a reply.

 

Anyone?

post-22350-1280701432.jpg

Share this post


Link to post
Share on other sites

Ouch.

 

Although the DS strobes are well built, that area is probably the weakest point, taking all the stress from the battery attachment. The quick release is a nice feature but you are showing us it's downside.

 

Is it possible that you tried to close the rear toggle without the battery pack being quite properly seated.

 

Certainly don't use it until it is fixed, there is a high possibility of a flood.

Share this post


Link to post
Share on other sites

Exactly the same thing has happened to one of my Ds-125 strobes.

 

I rescued a dive trip by using super glue to rebuild the plastic after it really crumbled which lasted a full week of diving with recharging every couple of dives.

 

I'd be very interested in the reply from Ikelite as I haven't sent mine back to them yet. Its a real pain, and not cheap, if you don't live in the US.

 

Mark

Share this post


Link to post
Share on other sites

So I'm not the only one...

 

Paid $45 to send it to the US. Will see in a few weeks what the total cost will be... Only sent the head, and not the battery though, becuase I use two Strobes and switch batteries between them and should really send the whole bunch... But I can't be without a strobe that long...

Share this post


Link to post
Share on other sites

I will be interested to hear how it gets fixed.

I've had really good luck with Ikelite customer service in the service and repair department!

 

Just noticed on the first day of a week of all day underwater photo shoots (kids) that the head of the bolt holding my strobe arm adapter BROKE OFF! For now it seems mostly secure, but a little wobbly, but have no idea how to get the durn thing back out!

Share this post


Link to post
Share on other sites

asmigel - that's a common problem with the DS-125 strobes, and was due to a defective product. If you contact ikelite they'll ship you a replacement part for it. the following was posted on the ikelite site, i just can't find it now:

 

6/22/09 .... DS125 and DS160 Battery Packs

Several broken battery packs for DS125 and DS160 strobes have been traced to a material inconsistency. Battery packs produced between Sept '07 and Nov '08 are subject to this flaw in the central black plastic mounting piece.

 

A date code with the format MM/YY is etched on each pack opposite the product number #4066.5. Packs produced after Nov '08 or which have been returned to Ikelite for any reason since Dec '08 have been updated to a newer style toggle pawl. This appears to have corrected the issue.

We recommend the updating of these battery packs as a preventative maintenance measure. If you have a broken toggle pawl or a battery pack within the above date range in its original condition, toggle replacement kits are available.

Share this post


Link to post
Share on other sites

Thanks! I will definitely contact them and get it sorted out.

 

~Abi

Share this post


Link to post
Share on other sites

That strobe will leak in that condition, if not now, soon. Good that you returned it.

Edited by Don in Colorado

Share this post


Link to post
Share on other sites
Sign in to follow this  

Sponsors

Advertisements



×
×
  • Create New...