Jump to content
Sign in to follow this  
zaven62

Nauticam rust problem

Recommended Posts

I have noticed "rust" forming on the inside edge of the eyepiece housing on my Nauticam Ad-90. I usually let the housing soak in luke warm water for about 2-3 hours after every dive, but that hasn't seemed to prevent corrosion forming here. I'm finding it very hard to accept corrosion on my pride and joy, and want it gone........now!

I can't get to the corrosion unless I remove the eyepiece housing, but I'm not sure about doing that.

Anyone else with the same problem or solution?

post-23531-1306737258.jpg

post-23531-1306737270.jpg

post-23531-1306737276.jpg

Edited by zaven62

Share this post


Link to post
Share on other sites
yes my also, i take it off and clean it.....

Thanks for your reply, how did you remove the locking ring?

Share this post


Link to post
Share on other sites

As a possible future customer I'm wondering if Nauticam has changed the grade of this Stainless Steel ring for the later model

housings? It's not the first time I've seen someone post about this issue so doesn't seem to be just a user maintenance fault.

 

Cheers,

Jim.

Share this post


Link to post
Share on other sites

Hi All,

 

Despite specifying high grade stainless steel when ordering material from vendors, Nauticam did see some parts shipped that had surface tarnishing or rust indicating a lower grade material was actually received. Once the issue was known, Nauticam started testing every stainless steel delivery when received to verify that the correct material was delivered. This extra quality control step has effectively eliminated this problem in new models, and I'm sure your local dealer will be happy to replace the part under warranty.

 

Cheers,

Chris

Share this post


Link to post
Share on other sites
Thanks for your reply, how did you remove the locking ring?

 

now i'm using inon 45vf and it come with too to remove it.........i will clean my camera when i know that i will not using it for long time...

Share this post


Link to post
Share on other sites
Thanks for your reply, how did you remove the locking ring?

As you can see, it is designed to use your 'finger' to open it. I don't use any tool on this.

 

After remove it, you need real extra care on 3 o-rings & these are very soft o-rings.

 

The rust should be easy one to remove. When I see something like this, I test it with

small magnet as good grade stainless steel will not stick to the magnet.

 

Sam

Share this post


Link to post
Share on other sites

Sam, it is not exactly accurate that all T316 is austenitic. If I remember correctly, it is the materials like Chromium (Cr) and Mo (I use the symbols cause I can't remember how to spell it! :)) that give stainless steel their resistance to corrosion, and Ni and Mn to lower ferritic properties. When stainless steel is cold worked, it can transform to be ferrite, by transformation of martensites (sp?). Thus while the magnet test is a test lots of people use to sort 300 series steel, it can be wrong.

That said, it seems that Nauticam had QC issues with the quality of their stainless steel parts. The magnet test, while possibly inaccurate, is a good test, since the alternatives like spark and acid aren't exactly going to work! :B):

In fact, recently I did such a test on the Nauticam D7000 housing and found several parts to be ferritic, including the locking mechanism. I subjected the magnet test to the Seacam and Subal D7000 housing and all points were austenitic. Now as I said, the magnet test doesn't necessarily mean anything on its own, but with CP's statement about the lower grade steel being used, it could mean something and owners would do well to check their housings more vigilantly, especially those with housings that are older as this problem would probably manifest later in the the life cycle.

Share this post


Link to post
Share on other sites

i have the same corrosion on my viefinder ring ...

 

and i also had corrosion on my locking latches after the first dives – my dealer replaced them FOC though straight away and i haven't had problems on the latches since then.

Share this post


Link to post
Share on other sites

Nauticam are aware of this issue on a very small number of the early housings and have effectively eliminated this as Chris points out above. Any Nauticam owner experiencing this, or any other issue with our products is encouraged to contact their dealer who will replace or repair under warranty. Anyone not 100% satisfied with the response from their dealer is welcome to contact myself and I will be happy to direct issues to the correct channels.

Share this post


Link to post
Share on other sites
Nauticam are aware of this issue on a very small number of the early housings and have effectively eliminated this as Chris points out above. Any Nauticam owner experiencing this, or any other issue with our products is encouraged to contact their dealer who will replace or repair under warranty. Anyone not 100% satisfied with the response from their dealer is welcome to contact myself and I will be happy to direct issues to the correct channels.

Would love to do that but I got my housing from Mike L. LOL

Bill

Share this post


Link to post
Share on other sites

My housing has been in and out of the water for over a year now, and no corrosion that I can see...

 

Tim

 

:)

Share this post


Link to post
Share on other sites
Nauticam are aware of this issue on a very small number of the early housings and have effectively eliminated this as Chris points out above. Any Nauticam owner experiencing this, or any other issue with our products is encouraged to contact their dealer who will replace or repair under warranty. Anyone not 100% satisfied with the response from their dealer is welcome to contact myself and I will be happy to direct issues to the correct channels.

Some of the earlier housings (mine included) are out of the warranty period, I wonder if Nauticam would replace/repair these "out of warranty housings" FOC as a gesture of good faith towards the many who bought early from a newly established company?

Share this post


Link to post
Share on other sites

I own the Nauticam D7000 housing, and I too have noticed a ring of rust around the viewfinder. If this is a problem that only pertains to early Nauticam models and was addressed and fixed, then my D7000 must have slipped through the cracks. I'm happy to hear that it should be able to be fixed free-of-charge, but there definitely appears to be a quality control issue.

Share this post


Link to post
Share on other sites

wrayphoto, I'm guessing you have a different issue. If you pop the viewfinder out you'll probably see that the rust is localized around the spring pins that prevent rotation. Some of these pins have been rusting in recent models, and will also be replaced free of charge. Email innovation at nauticamusa.com, and Chris will get some parts down to you.

Share this post


Link to post
Share on other sites
wrayphoto, I'm guessing you have a different issue. If you pop the viewfinder out you'll probably see that the rust is localized around the spring pins that prevent rotation. Some of these pins have been rusting in recent models, and will also be replaced free of charge. Email innovation at nauticamusa.com, and Chris will get some parts down to you.

I had an issue on my 180 deg viewfinder that suffered some corrosion after the anodising got stretched. A quick call to Alex T and the viewfinder was on its way from Egypt, then back to the factory back to UK and returned to me in 3 week FOC. The stem of the viewfinder is completely new and the entire thing looks like new. They even supplied new covers and the neoprene pouch which I forgot to send back. You cant argue with service like that.

 

Things break, fact!

 

What happens when they break is the important thing and Nauticam in my experience are very keen not only to solve your issue but investigate it to prevent it happening again!!!

 

Thanks Mr T!!!!

 

Duncan

Share this post


Link to post
Share on other sites

After further investigation, it does appear that the rust issue I've experienced is due to the spring pins in place to prevent rotation. Everyone at Nauticam has been very prompt to respond to my inquiries and help resolve the issue as soon as possible.

Share this post


Link to post
Share on other sites
Sign in to follow this  

Sponsors

Advertisements



×
×
  • Create New...