Jump to content
Nigel Motyer

Aquatica D7000 housing problems

Recommended Posts

Hi folks,

 

I had problems with my new Aquatica D7000 housing (got it in June) and wondered if it was just me or are others having the same issues.

 

I just returned from a trip out to Cocos, we had good shark action but I had real problems with my housing. I had done about 20 dives with it over the couple of months before the trip and had had a couple of issues with the Flash activation leaver when using the optical connector. If I depressed the onboard camera flash with the leaver on the housing when underwater then it sometimes wouldn't/couldn't be reactived while under water, it always worked when back on the boat though so I never really tracked down what the issue was as it didn't happen every time.

 

At Cocos Is though I had real problems with the buttons on the back of the housing, especially the focus selection buttons. The "9 o'clock" button kept sticking in if depressed once below the 20-25meter depth, which is pretty much every dive in Cocos. It looks like the spring tension on the buttons isn't sufficient to push the button back out again when you remove your finger. Certainly this button feels stiffer to depress than some of the others. On occasion other buttons stuck too and depending on what button stuck and what mode the camera was in at the time the camera sometimes locked up and wouldn't fire until you could free the button back out again. It was often hard to figure out which button it was, so I ended up trying to pull them all back out manually. Not easy wearing gloves and very frustrating as you are missing photo ops. If I hit image preview, the camera would scroll endlessly through the images until you could free the button. Often I couldn't access preview at all and also was unable to engage live view on occasion. Sometimes Live view would come on but "record" wouldn't engage. When I could shoot video, because the buttons were stuck in, the video focus selection just kept shifting to the left of the frame resulting in any shark in the centre of the frame being out of focus. Something I often couldn't see till I was back on the surface. These are minor issues to resolve but really frustrating.

 

I also had the problem with the flash not triggering, I'm really not sure why, perhaps the onboard flash had been depressed but it certainly wouldn't flip up again unless I came up to shallow water or opened the housing. In the end I scrapped the optical connections and reverted to hard wired connections and this solved the flash issue.

 

The button problems persisted all week though. I know these housings have had issues with Live View selection, there is a post on the Aquatica website about that but I had not heard there was a problem with the buttons sticking - has anybody else had these issues or is it just my housing ? Perhaps I just got a friday afternoon housing, the Aquatica name tag fell off it this morning as I unpacked it ! Serial No of mine is 20068HYB - 108. I'd imagine its a simple fix, perhaps a stronger spring, or a new button shaft but it really buggered up several dives during a great trip for me.

 

Its a shame these are good housings, really well designed and when working well they are a joy to use. Aquatica are usually great on service too so I know they will sort out the issue but has anybody else had these problems ?

 

post-17859-1316261237.jpg

Share this post


Link to post
Share on other sites

Yes Nigel, if I remember correctly, you have one of the earlier batch, and some units did have the tolerance too tight, you should have contacted me the moment you had an issue, I would have sent you the fix kit overnight, its not like you to be shy :D, (actually you guy's should always knock on the manufacturer's door whenever you have an issue, usually we, and our competitors as well, are well informed on any possible issues that might arise)

 

Shoot me a e-mail at jean@aquatica.ca with your address and phone number and I will Fedex a fix kit to you ASAP. Most likely early next week

Share this post


Link to post
Share on other sites
Its a shame these are good housings, really well designed and when working well they are a joy to use. Aquatica are usually great on service too so I know they will sort out the issue but has anybody else had these problems ?

 

Great picture Nigel.

 

This thread has some info on others problems:

http://wetpixel.com/forums/index.php?showtopic=42223

 

Although it should always be noted these are the exceptions, rather than the norm. Forums tend not to get posts from those not having problems. Not that it will comfort you, but one of my group here in Indonesia has the Aquatica D7000 and it is going great. At least the latest from the World Cup should be cheering you up.

 

Alex

Share this post


Link to post
Share on other sites
Great picture Nigel.

 

This thread has some info on others problems:

http://wetpixel.com/forums/index.php?showtopic=42223

 

Although it should always be noted these are the exceptions, rather than the norm. Forums tend not to get posts from those not having problems. Not that it will comfort you, but one of my group here in Indonesia has the Aquatica D7000 and it is going great. At least the latest from the World Cup should be cheering you up.

 

Alex

 

 

I love my new Aquatica D7000! Thanks to Backscatter and Aquatica for getting me set up for a trip of a lifetime in Indonesia. It has been a seamless transition from the using the D200. I really like the lighter weight of the housing, and love the option for fiber optic connections for my strobes, 4 less o-rings to clean/lube :D

 

Thanks,

Kathryn

 

dreamsofblue.com

Edited by karant

Share this post


Link to post
Share on other sites
I love my new Aquatica D7000! Thanks to Backscatter and Aquatica for getting me set up for a trip of a lifetime in Indonesia. It has been a seamless transition from the using the D200. I really like the lighter weight of the housing, and love the option for fiber optic connections for my strobes, 4 less o-rings to clean/lube :D

 

Thanks,

Kathryn

 

dreamsofblue.com

 

 

And TTL fully functional now!

Share this post


Link to post
Share on other sites
Yes Nigel, if I remember correctly, you have one of the earlier batch, and some units did have the tolerance too tight, you should have contacted me the moment you had an issue, I would have sent you the fix kit overnight, its not like you to be shy :),

 

Many thanks Jean, not shy though just 500 kms off shore and hard to suck up an internet connection out there ! :D

 

This is my 4th Aquatica housing, you guys have really raised your game here, the quality and standard of what you have produced is league change from previous models. I like this housing and Aquatica should be congratulated for producing such a neat unit at such a great price point. Don't get me wrong, I know what we are dealing with here is early stage production niggles and I'm confident you will fix them.

 

I did check the Aquatica website when I got back ashore in Costa Rica and there was a post there about an issue with Live view but it didn't seem to me to recognise the button or flash activation leaver problems which as a stills shoter were my first concern. I didn't have your e-mail contact on my laptop when I was still in Cost Rica so I thought I'd check in with the Wetpixelers to see if its not just me.

 

The link that Alex highlights on the post below shows some other folks seem to be having the same or similar issues with the "on camera" Flash activation leaver and I think also on the buttons. I can see you are getting back to folks by PM but I can't see if you have a solution for the three issues mentioned. Live view, Flash Leaver and sticky buttons. If you do it might help if there was a post on the Aquatica website because as you can imagine, I'd have love to have known that before heading out to Cocos Island. These are expensive trips and the last thing you want to be told after the trip is over is that if you had asked, we'd have told you there was a known fix for that.

 

I'll drop you a PM now, but thanks for coming back to me Jean. Regards N.

Share this post


Link to post
Share on other sites

Sponsors

Advertisements



×
×
  • Create New...