Jump to content

Recommended Posts

Hi everyone, I have an issue that's probably more common sense than I'll admit to myself. I've just purchased an Ikelite 5510.22 port body to replace the smaller 5510.16 that I had been using and I'm stumped. I assumed that the body would mate to my 8" port just as the .16 had and I was wrong. In tightening the new port body down it threads initially but gets too tight without coming close to making a seal. I replaced the old port body just to verify the fit and it mated without an issue. Then I swapped o-rings, cleaned and checked the threads and inspected for any warping on the body and still nothing. Neither ikelite or adorama keep reasonable business hours for someone living in Hawaii and ikelite's frequently asked questions somehow seem to exclude the possibility of anyone having a similar issue so I'll put it out there...anyone have any idea what's going on here? Why can't I screw the 5510.22 into the port assembly?

I'd really like to dive this setup in the morning but there's no way I'm putting an already touchy housing in the water with a 1/4" gap between the port and body.

Thanks in advance for any words of wisdom here!

Cheers,

 

Jim

Share this post


Link to post
Share on other sites

i have had the same problem with a Ikelite wide angle port, sometimes they are tight to start with but as long as you have the correct components and they are lined up correctly you should be able to keep screwing it together slowly. Hope it works out.

 

Loza

Share this post


Link to post
Share on other sites

Try putting this together and taking it apart without the o-ring a couple of times just to make sure it will go together. The other trick is put some o-ring grease ikelite only on the parts as well as the o-ring and the edge where the o-ring goes into the dome port. I trust that the reason for selecting the 5510.22 is that you are using a different lens?

Share this post


Link to post
Share on other sites

I also have the 8" dome, and two port bodies for different lenses.

 

Since the first day one of the port bodies has been much stiffer to install than the other, but over the three years I've had them there have not been any leak problems as long as I made sure there is no gap between the body and dome.

 

Sometimes takes two people to get the stiff one back off again, just to grip and turn it properly.

 

The stiff one did improve slightly after being used several times, but it is still noticeably harder to turn.

Edited by BigJeff

Share this post


Link to post
Share on other sites

In reguards to taking the port off the dome, I have found that when you assemble it that you turn it as tight as possiable then back it off 1/8 of a turn it will come apart eisier latter. I always carry two strap wrenches to assist with the ports.

Share this post


Link to post
Share on other sites

Sponsors

Advertisements



×
×
  • Create New...