Jump to content
echeng

Embedding media on the new Wetpixel

Recommended Posts

Hello, everyone. The new Wetpixel embeds videos and pictures very differently than does the old one. There is no more need to use bbcode (bbcode for images will still work, but bbcode for video embeds will no longer work). To embed, just paste the URL into the body. We currently support:

  • jpg
  • gif
  • png
  • YouTube
  • Google Video
  • MySpace Video
  • GameTrailers
  • Flickr Image Set
  • MP3
  • Vimeo
  • Lytro living pictures
  • Flickr Video (removed 2/25/13)
  • Windows Media Player (hosted .wmv files)

I'd love to support Flickr images, as well, but their embeds are a little more complicated. I have to give it another try.

 

Any other embed desires?

Share this post


Link to post
Share on other sites

Smugmug?

Share this post


Link to post
Share on other sites

I wish! Smugmug has a bunch of IDs in its URL, and some of the code used in the embed is not discoverable by URL.

 

Here's a typical URL:

 

 

http://photos.echeng.com/Prints/Print-Sales/3381454_KFBCGG#!i=189233567&k=2GxQNf6

 

... and how it wants to be embedded:

 

 

<a href="http://photos.echeng.com/Prints/Print-Sales/3381454_KFBCGG#!i=189233567&k=2GxQNf6&lb=1&s=A" title="Juvenile loggerhead turtle (Caretta caretta) being released into the wild in Palm Beach, Florida"><img src="http://photos.echeng.com/Prints/Print-Sales/i-2GxQNf6/2/M/echeng10082-M.jpg" title="Juvenile loggerhead turtle (Caretta caretta) being released into the wild in Palm Beach, Florida" alt="Juvenile loggerhead turtle (Caretta caretta) being released into the wild in Palm Beach, Florida"></a>

 

I don't see the filename ("echeng10082-M") in the URL, so I don't think I can do automatic embedding.

Share this post


Link to post
Share on other sites

Oh well it was worth asking. I guess it works for the ADVrider.com forum as that site was created by the Smugmug people

Share this post


Link to post
Share on other sites

Yeah. Well, if I hack something that uses the Smugmug API, it may be possible. Do you have a link to a post with a URL-embedded Smugmug picture on that forum? Maybe there's another way.

Share this post


Link to post
Share on other sites

Eric,

 

Here is the thread http://advrider.com/forums/showthread.php?p=20763842#post20763842

 

this uses a BBCode link.

 

MLW%20%2711%20054-M.jpg

 

This uses a photo link:

 

http://scottpowell.smugmug.com/Motorcycles/MLW-2011-1/i-zLzH7tD/1/M/Powell_20110522_8871-M.jpg

Edited by Ronyx

Share this post


Link to post
Share on other sites

Thank you. Do you know offhand the format of the bbcode link?

Share this post


Link to post
Share on other sites

Does this help. This one is for a different picture

Edited by Ronyx

Share this post


Link to post
Share on other sites

Oh. You can always use the standard image bbcode to embed things. That is no problem. But I can't get enough information from the main URL to auto-embed.

Share this post


Link to post
Share on other sites

Lol, I had a feeling I didn't know what I was talking about.

  • Like 1

Share this post


Link to post
Share on other sites

Good to have an upgrade. Thanks. But this means that every bit of video that has ever been posted/embedded here now no longer displays?

Share this post


Link to post
Share on other sites

That is true. I'll add to my list a TODO item to go back and revive all of them.

Share this post


Link to post
Share on other sites

That is true. I'll add to my list a TODO item to go back and revive all of them.

Thanks Eric. And thanks for the RSS feeds again. Working perfectly.

Share this post


Link to post
Share on other sites

...I'd love to support Flickr images, as well, but their embeds are a little more complicated. I have to give it another try.

 

Any other embed desires?

I noticed that if you link to the 'set' link in Flickr, it shows up automatically as a flash-based slide show here. Just checked and one I posted like that before the migration still works. I think Flickr is just fine, with this.

Share this post


Link to post
Share on other sites

I've removed the Flickr video embed. The regexp system here for matching is a bit weird, and I can't find a way to match only embedded video while leaving other Flickr links alone. So your Flickr URLs should all work again without creating the empty embed. Flickr sets still work.

Share this post


Link to post
Share on other sites

Imageshack?

I'm not sure anyone uses it, except me...

 

Edit: Thanks for the site by the way.

Edited by Prop Joe

Share this post


Link to post
Share on other sites

Heh. Probably not popular enough to support... :)

Share this post


Link to post
Share on other sites

Sponsors

Advertisements



×
×
  • Create New...