Jump to content
Sign in to follow this  
chrism

Problem with YS90 velcro connection?????

Recommended Posts

In a very Homer Simpson way, I screwed up the supplied velcro TWICE, although one could be cut so it fit. No worries to get another piece at the fabric store, just haven't done it.

 

However, two problems:

 

(1) there is a tiny sliver of space of the diffuser that is not covered. it seems I am getting some light bleed at the sides. Although the 4040 is set at -2 flash, is it coming from this area?

 

(2) the velcro comes loose at inopportune moments. There's plenty to hook onto, it just comes loose/off easily. Anyone else experience this?

 

Has anyone come up with a better connection than the velcro? I'm thinking a piece of plastic to fit over the entire diffuser or something?

 

Chris

Share this post


Link to post
Share on other sites

1) Are you talking about the diffuser over the internal flash? Haven't noticed any light bleed from it.

 

2) I've never had the velcro come loose, so far. It seems very secure but then again, you have many more dives on yours than I do. Maybe it's a durability issue.

 

guess I wasn't much help, huh? :)

Share this post


Link to post
Share on other sites

thanks for answering anyway!

 

Yes, I mean the plastic dffuser over the internal flash

 

looks like I need to go to the fabric store.

 

CHris

Share this post


Link to post
Share on other sites
Sign in to follow this  

Sponsors

Advertisements



×
×
  • Create New...