Jump to content

Recommended Posts

Hi,

 

My Nauticam NA-EM5 housing's shutter lever doesn't return to it's original position after pressed sometimes. This more frequently happens when I depress the lever partially (half way to focus). Inside the housing I've noticed the spring loaded lever that pushes on the camera's shutter button doesn't move smoothly but the external shutter lever is smooth. Anyone else have this problem? I was thinking about putting some silicon liquid on the internal lever. Any recommended silicon that's safe for housing?

I take good care of my housing (rinse, soak after day's diving).

 

Thanks

 

Jason

Share this post


Link to post
Share on other sites

I have found the same problem after a lot of use underwater despite long soaks etc.
I adjusted the screw holding the lever return bracket that sits on the left of the lever inside the housing - I did not add silicone. This helped the problem until I could get the housing serviced.

Share this post


Link to post
Share on other sites

jander4454,

Thanks! This seems to have made the shutter lever smoother and return to it's original position.

Do you know what was done when you got your housing serviced? Replacement parts? I'm wondering since loosening the screw seemed to have fixed it. Will need to dive with it.

Jason

Share this post


Link to post
Share on other sites

Last year I found out that the bearings of the D800 Nauticam housing were swelling in the water. Nauticam replaced them with a new plastic, and the shutter release doesn't stick any more.

Share this post


Link to post
Share on other sites

tdpriest,

Ah, thanks for the info. After my first "fix" via jander4454's suggestion, the shutter action was again not smooth. After looking into my housing and playing with a few internal levers, I discovered that the lever with a spring that contacted my camera shutter was too snugly fit on the plastic shaft it rotated around. The lever still had a hard time rotating even after loosening screw that held the lever onto the shaft. I then just gently sanded the hole on the lever where the shaft goes in and it now rotates freely.

Share this post


Link to post
Share on other sites

Sponsors

Advertisements



×
×
  • Create New...