Jump to content
Sign in to follow this  
gnitzan

Ikelite 8" Domeport with Nikkor 10.5mm shade in frame

Recommended Posts

Hi,

 

Yesterday was my first UW shooting with my new Ikelite D7100 housing (2 DS161) and with Ikelite 8" dome port with 2.75" extension recomended by Ikelite for the Nikon 10.5mm.

 

For some reason all my shots had my dome shade (sample attached).

 

I know I can remove the shade, however, if its the recommended size shouldn't it fit perfectly? am I missing something?

 

I have followed all manual instructions and I could not find any mention of this problem.

 

I guess I did something wrong. Has any one ran into this problem with a similar setup?

 

Thanks,

 

Gal

post-46712-0-29523000-1399319717_thumb.jpg

Share this post


Link to post
Share on other sites

Can you post a picture of your port extension and dome please?

Share this post


Link to post
Share on other sites

Hi, Its the same as the one in the link in my post. The port was threaded snugly all the way to the extension.

 

Gal.

 

Sent from my Nexus 5 using Tapatalk

Share this post


Link to post
Share on other sites

He wants to see if you have the shade turned wrong, If its 90 degrees off, you will see the port.

 

Hi, Its the same as the one in the link in my post. The port was threaded snugly all the way to the extension.

Share this post


Link to post
Share on other sites

Ohhhh , of course it was assembled wrong.

 

Thank you so much.

 

Gal.

 

Sent from my Nexus 5 using Tapatalk

Share this post


Link to post
Share on other sites
Sign in to follow this  

Sponsors

Advertisements



×
×
  • Create New...