Jump to content
dpoursanidis

Aquatica 40D internal rotation system

Recommended Posts

Hello Wetpixel community



I face an issue with my Aquatica housing and i need a help as i cannot solve it by myself (i try lots of different solves but nothing work).



As you can see in the image the red cirlced part is the one that rotate the back control of the camera and change the aperture as well as other controls. This part doesn't function as it has and i have to rotate it lots of times in order to chane it - it spins and glides. I change ths small rubber ring but no solution. I add some more rubber on, nothing. I assume that the problem comes from the green string.





What can i use in order to replace the green string ?



Or any other opinion / solution ?



Does anybody face similar issue in the past ?



Dimitris



https://www.dropbox.com/s/1xgbmlxked4bzl6/_MG_1264%20b.jpg


Edited by dpoursanidis

Share this post


Link to post
Share on other sites

Dimitris, it looks like a Canon 30D housing, when you push the plate with the rubber wheel, does it spring back? there should be a spring underneath the flat plate to create some pressure on the control of the camera, its possible that it fell, let me know at jean@aquatica.ca, we should be able to get you back in the water with the housing soon.

Share this post


Link to post
Share on other sites

Dear Jean

 

I check it and yes, is on position. I also see that t can adjust the plate by screw/unscrew the two low allew screws.

Any other advice/ solution ?

Share this post


Link to post
Share on other sites

Sponsors

Advertisements



×
×
  • Create New...