Jump to content
Ribeiro dos Santos

Help needed: Nikon D7100 wont work with Sea & Sea YS TTL Converter /N

Recommended Posts

Hi all,

 

Recently I bought a Sea and Sea YS /N TTL converter. (By the way, thanks again, Reubencahn, for it.)

Though it's used it is in excellent shape. I tried it with my 2 Sea and Sea YS 90 Auto Duo and Nikon D70 and worked flawlessly.

Then I tried the same set with my Nikon D7100 and TTL doesn't work. At first I thought it was some circuit inside Nauticam bulkhead...

 

So I tested D7100 in the same exact wiring set up that I use the D70: with the D70 housing opened, connected its hotshoe to D7100 - no TTL!

 

I also have a Subtronic Nova that I use with both cameras and TTL works well, so I'm out of solutions.

 

Does anybody has experience with D7100 and Sea & Sea TTL?

 

Any help would be appreciated.

 

Cheers

 

Alex

Share this post


Link to post
Share on other sites

According to S&S, for the 7000 at least the converter needs to be upgraded to one with the white dot.

Bill

Share this post


Link to post
Share on other sites

Thank you, Bill, for your answer, but please explain:

 

I don't see any white dot in mine so what am I supposed to do?

 

- Send it to Sea & Sea for an upgrade?

- Throw it in the trash bin?

 

I tried to contact Sea & Sea in Portugal, but the link is dead for ages. Then e-mailed Sea & Sea UK but still no answer...

Share this post


Link to post
Share on other sites

Sponsors

Advertisements



×
×
  • Create New...